Bug 801063 - [RFE] Ability to configure sound pass-through to appear as MIC as opposed to line-in
Summary: [RFE] Ability to configure sound pass-through to appear as MIC as opposed to ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 6.4
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 816503
TreeView+ depends on / blocked
 
Reported: 2012-03-07 15:23 UTC by David Juran
Modified: 2015-09-28 02:02 UTC (History)
9 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.307.el6
Doc Type: Release Note
Doc Text:
Configurable Sound Pass-through A sound device can now be detected as a microphone or a speaker in the guest system (in addition to being detected as line-in and line-out). Sound devices can now function properly in guest applications that accept only certain types of input for voice recording and audio.
Clone Of:
: 816503 (view as bug list)
Environment:
Last Closed: 2013-02-21 07:32:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0527 0 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2013-02-20 21:51:08 UTC

Description David Juran 2012-03-07 15:23:19 UTC
Description of problem:
When running a Windows7 VM in RHEV, the sound device that is passed through SPICE is presented to the VM as line-in but some applications (notably Microsoft Live Meeting) require this as a MIC. I therefore suggest that we make it a configurable how the sound device is presented

Comment 3 Gerd Hoffmann 2012-03-08 08:53:03 UTC
scratch build:
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=4129196

Testing: Use "-device hda-micro" instead of "-device hda-duplex" on the qemu-kvm command line.

Expected behavior:  Windows7 starts hardware detection on first boot with hda-micro active.  Start -> Control Panel -> Hardware and Sound -> Manage audio devices -> Recording tab -> see microphone instead of line-in there.

Comment 4 David Juran 2012-03-08 10:31:58 UTC
Not too good results, qemu-kvm segfaulted while windows was booting up with the following message in syslog:

Mar  8 10:28:22 rhevh2 kernel: qemu-kvm[30366]: segfault at 50 ip 00007fdac66931e5 sp 00007fdabee2f9a0 error 4 in libspice-server.so.1.0.2[7fdac665f000+e2000]


Running this on rhev-H hosts, so not much more info available...

Comment 5 Gerd Hoffmann 2012-03-08 10:52:00 UTC
Any chance to pickup+install latest spice-server package from brew on that machine and see how it goes then?  Failing that I'll go build a 6.2 version.

Comment 6 David Juran 2012-03-09 14:47:59 UTC
On the bright side, with spice-server-0.10.1-4.el6, qemu-kvm no longer crashes.
On the not-so-bright side, is there any (easy) way I can test this in a RHEV environment? I.e. start a VM with the hda-micro parameter?

Comment 9 Sibiao Luo 2012-07-10 03:04:40 UTC
Hi all,

   I reproduce this issue on qemu-kvm-0.12.1.2-2.295.el6.x86_64 as following.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
guest info:
windows_7_ultimate_sp1_x64

Steps to Reproduce:
1.boot a windows 7 guest with "-device hda-duplex".
eg:<qemu-kvm-command-line>-device intel-hda,id=sound0,bus=pci.0 -device hda-duplex
2.check "Start -> Control Panel -> Hardware and Sound -> Manage audio devices -> Recording tab".

Reproduce results:
after the step 2, we could see "line-in" device in Recording tab.


   I also test the Gerd's build Comment #8 with the same steps using "-device hda-micro" instead of "-device hda-duplex" on the qemu-kvm command line. The test results is that we could see "Microphone" instead of "line-in" device there.

Best wish.
sluo

Comment 14 Sibiao Luo 2012-11-23 05:02:08 UTC
Verify this bug on qemu-kvm-0.12.1.2-2.334.el6.x86_64.

host info:
# uname -r && rpm -q qemu-kvm
2.6.32-342.el6.x86_64
qemu-kvm-0.12.1.2-2.334.el6.x86_64
guest info:
windows_7_ultimate_sp1_x64

steps:
the same as comment #9

Result:
we could see "Microphone" device in Recording tab instead of "line-in" there, "Start -> Control Panel -> Hardware and Sound -> Manage audio devices -> Recording tab".

Base on above and comment #9, this bug was fixed correctly.

Comment 16 errata-xmlrpc 2013-02-21 07:32:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html


Note You need to log in before you can comment on or make changes to this bug.