Bug 801070 - Better error message for deleting envs from middle of the path
Better error message for deleting envs from middle of the path
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Petr Chalupa
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 10:41 EST by Tomas Strachota
Modified: 2015-05-04 21:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 14:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Strachota 2012-03-07 10:41:02 EST
Description of problem:

Error message after an attempt for deleting an environment that has some successors needs to be polished.


Version-Release number of selected component (if applicable):
katello-cli-0.2.8-1
katello-0.2.8-1

Steps to Reproduce:
1. katello create environment --name Dev --org ACME_Corporation --prior Library
2. katello create environment --name Prod --org ACME_Corporation --prior Dev
3. katello environment delete --name Dev --org ACME_Corporation
  
Actual results:
Errors occured during orchestration #<OrderedHash {:base=>["Environment Dev has a successor.  Only the last environment on a path can be deleted"]}>
 Queue Failed - []

Expected results:
Simplier error message without data types and orchestration info.
Eg. "Environment Dev has a successor.  Only the last environment on a path can be deleted"
Comment 2 Petr Chalupa 2012-03-13 11:25:38 EDT
fixed in 02a831c599767f909ce84c75707c0aec0e1623ee
Comment 6 Sachin Ghai 2012-03-19 02:40:30 EDT
verified with following CFSE build.

[root@perceptor ~]# rpm -qa | grep -ie katello-0 -ie katello-cli
katello-0.1.304-1.el6.noarch
katello-cli-common-0.1.105-1.el6.noarch
katello-cli-0.1.105-1.el6.noarch

Error message is improved now:

[root@perceptor ~]# katello -u admin -p admin shell
katello> environment create --name dev --org ACME_Corporation --prior Library
Successfully created environment [ dev ]
katello> environment create --name prod --org ACME_Corporation --prior dev
Successfully created environment [ prod ]
katello> environment delete --name dev --org ACME_Corporation
Environment dev has a successor. Only the last environment on a path can be deleted.
katello> exit
Comment 7 errata-xmlrpc 2012-05-15 14:56:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html

Note You need to log in before you can comment on or make changes to this bug.