Bug 801081 - broken symlinks in /usr/lib/gcc/x86_64-redhat-linux/4.6.2/32
broken symlinks in /usr/lib/gcc/x86_64-redhat-linux/4.6.2/32
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 11:13 EST by nexus6roybatty
Modified: 2014-01-21 18:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 475054
Environment:
Last Closed: 2012-03-09 10:56:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nexus6roybatty 2012-03-07 11:13:12 EST
note:   reinstalling gcc, g++, and corresponding devel libraries does not resolve

following symlinks broken:
libgcc_s.so
libgomp.so
libmudflap.a
libmudflapth.a
libstdc++.a
libstdc++.so
libsupc++.a


see example below:
--------------------------------------------------------------------------------
[user@localhost 32]# pwd
/usr/lib/gcc/x86_64-redhat-linux/4.6.2/32                                                                                        
[user@localhost 32]# ls -l                                                                                                      
total 3484                                                                                                                       
-rw-r--r--. 1 root root    1740 Oct 27 07:37 crtbegin.o                                                                          
-rw-r--r--. 1 root root    2164 Oct 27 07:37 crtbeginS.o                                                                         
-rw-r--r--. 1 root root    2048 Oct 27 07:37 crtbeginT.o                                                                         
-rw-r--r--. 1 root root    1312 Oct 27 07:37 crtend.o                                                                            
-rw-r--r--. 1 root root    1568 Oct 27 07:37 crtendS.o                                                                           
-rw-r--r--. 1 root root    4612 Oct 27 07:37 crtfastmath.o                                                                       
-rw-r--r--. 1 root root    2460 Oct 27 07:37 crtprec32.o                                                                         
-rw-r--r--. 1 root root    2468 Oct 27 07:37 crtprec64.o                                                                         
-rw-r--r--. 1 root root    2460 Oct 27 07:37 crtprec80.o                                                                         
-rw-r--r--. 1 root root 3334202 Oct 27 07:43 libgcc.a                                                                            
-rw-r--r--. 1 root root   42622 Oct 27 07:43 libgcc_eh.a                                                                         
lrwxrwxrwx. 1 root root      18 Feb 10 16:02 libgcc_s.so -> /lib/libgcc_s.so.1
-rw-r--r--. 1 root root   33838 Oct 27 07:43 libgcov.a
-rw-r--r--. 1 root root   93952 Oct 27 07:43 libgomp.a
lrwxrwxrwx. 1 root root      28 Feb 10 16:02 libgomp.so -> ../../../../libgomp.so.1.0.0
lrwxrwxrwx. 1 root root      45 Feb 10 16:02 libmudflap.a -> ../../../i686-redhat-linux/4.6.2/libmudflap.a
-rw-r--r--. 1 root root      39 Oct 27 07:38 libmudflap.so
lrwxrwxrwx. 1 root root      47 Feb 10 16:02 libmudflapth.a -> ../../../i686-redhat-linux/4.6.2/libmudflapth.a
-rw-r--r--. 1 root root      41 Oct 27 07:38 libmudflapth.so
lrwxrwxrwx. 1 root root      46 Feb 10 16:02 libquadmath.a -> ../../../i686-redhat-linux/4.6.2/libquadmath.a
-rw-r--r--. 1 root root      40 Oct 27 07:38 libquadmath.so
lrwxrwxrwx  1 root root      44 Mar  6 21:03 libstdc++.a -> ../../../i686-redhat-linux/4.6.2/libstdc++.a
lrwxrwxrwx  1 root root      31 Mar  6 21:03 libstdc++.so -> ../../../../libstdc++.so.6.0.16
lrwxrwxrwx  1 root root      44 Mar  6 21:03 libsupc++.a -> ../../../i686-redhat-linux/4.6.2/libsupc++.a

--------------------------------------------------------------------------------
+++ This bug was initially created as a clone of Bug #475054 +++

It shouldn't report the gcc-related verification errors below. The files in question are broken symlinks to 32-bit libs not installed on x86_64 system. Which rpm considers valid.

# rpm -Va |grep -v ' c '  
prelink: /usr/lib64/libOpenIPMIposix.so.0.0.1: prelinked file was modified
S.?.....    /usr/lib64/libOpenIPMIposix.so.0.0.1
.......T    /lib/modules/2.6.27.5-117.fc10.x86_64/modules.alias.bin
.......T    /lib/modules/2.6.27.5-117.fc10.x86_64/modules.dep.bin
.......T    /lib/modules/2.6.27.5-117.fc10.x86_64/modules.symbols.bin

# yum verify
Loaded plugins: changelog, fastestmirror, filter-data, list-data, remove-with-leaves, verify
==================== Installed Packages ====================
OpenIPMI-libs.x86_64 : The OpenIPMI runtime libraries
    File: /usr/lib64/libOpenIPMIposix.so.0.0.1
        Problem:  checksum does not match
        Current:  d41d8cd98f00b204e9800998ecf8427e
        Original: b26b02bcfee2364cd87bd550bdf9ef7d
                                   --------                                   
        Problem:  size does not match
        Current:   28 k
        Original:  25 k

gcc.x86_64 : Various compilers (C, C++, Objective-C, Java, ...)
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libgcc_s.so
        Problem:  file is missing
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libgomp.so
        Problem:  file is missing
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libmudflap.a
        Problem:  file is missing
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libmudflapth.a
        Problem:  file is missing

gcc-c++.x86_64 : C++ support for GCC
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libstdc++.a
        Problem:  file is missing
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libstdc++.so
        Problem:  file is missing

kernel.x86_64 : The Linux kernel
    File: /lib/modules/2.6.27.5-117.fc10.x86_64/modules.alias.bin
        Problem:  mtime does not match
        Current:  Sun Nov 30 16:50:08 2008 (12 days, 7:39:35 later)
        Original: Tue Nov 18 09:10:33 2008
    File: /lib/modules/2.6.27.5-117.fc10.x86_64/modules.dep.bin
        Problem:  mtime does not match
        Current:  Sun Nov 30 16:50:08 2008 (12 days, 7:39:35 later)
        Original: Tue Nov 18 09:10:33 2008
    File: /lib/modules/2.6.27.5-117.fc10.x86_64/modules.symbols.bin
        Problem:  mtime does not match
        Current:  Sun Nov 30 16:50:08 2008 (12 days, 7:39:34 later)
        Original: Tue Nov 18 09:10:34 2008
verify done

--- Additional comment from james.antill@redhat.com on 2008-12-07 02:09:50 EST ---

See the man page. The command verify-rpm should produce the same output as rpm, the other commands do not.

--- Additional comment from curtis@greenkey.net on 2008-12-07 12:25:36 EST ---

Sorry, wasn't clear. The bug still exists with verify-rpm. In particular, it's this part of the output that's inconsistent with rpm -V.

gcc.x86_64 : Various compilers (C, C++, Objective-C, Java, ...)
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libgcc_s.so
        Problem:  file is missing
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libgomp.so
        Problem:  file is missing
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libmudflap.a
        Problem:  file is missing
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libmudflapth.a
        Problem:  file is missing

gcc-c++.x86_64 : C++ support for GCC
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libstdc++.a
        Problem:  file is missing
    File: /usr/lib/gcc/x86_64-redhat-linux/4.3.2/32/libstdc++.so
        Problem:  file is missing

--- Additional comment from svidal@redhat.com on 2009-10-12 16:37:56 EDT ---

okay - it's the symlink lookup that's doing it - I've found a package to replicate it with and I'll hopefully have a fix shortly.

--- Additional comment from svidal@redhat.com on 2009-10-12 16:57:46 EDT ---

checked in a change upstream - waiting for ACK from someone else before it is pushed.

It fixes this problem.

I don't know if this fix will make it back to F10 but we should be able to get it into F11 and definitely as an update for F12.
Comment 1 Jakub Jelinek 2012-03-09 10:56:25 EST
This is not a bug, it is by design, to allow supporting both -m64 and -m32 compilation if both 32-bit and 64-bit devel packages are installed, but not forcing you to do that if you don't want to install the 32-bit packages (then only -m64 compilation will work).

Note You need to log in before you can comment on or make changes to this bug.