Bug 801130 - FC16 hangs on GRUB after system update
FC16 hangs on GRUB after system update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 13:05 EST by Bill Norman
Modified: 2012-03-07 16:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 16:02:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Norman 2012-03-07 13:05:24 EST
Description of problem: I have been running FC16_64, successfully on my laptop for several months. This is a dual boot configuration with Windows 7, which I hardly use.

I just did a Fedora system update that included installing a new kernel (3.2.9-1.fc16.x86_64). The update completed and I rebooted the system. The machine restarted but hangs up with the screen showing only GRUB and a flashing cursor.

I booted from the rescue disk and did chroot /mnt/sysimage. I see that /boot/grub2/grub.cfg has been modified to add the new kernel. But I do not see anything obvious that would cause the system to hang. 

This system obviously is dead. I cannot use Fedora or Windows. It is a real problem because it is my development system and I was in the middle of some important work. Can you please advise how I can get this system to boot?


Version-Release number of selected component (if applicable):3.2.9-1.fc16.x86_64


How reproducible:


Steps to Reproduce:
1. Start system
2. BIOS loads
3. Observe boot screen hangs with GRUB displayed and flashing cursor
  
Actual results:


Expected results: Grub should start and display a list of linux kernels and Windows 7 start options


Additional info:
Comment 1 Bill Norman 2012-03-07 16:02:59 EST
resolved by running 


# grub2-install --force /dev/sda

in the recovery session.

I had to use --force because I was seeing a set of warnings:

warn: Your embedding area is unusually small. core.img won't fit in it.

warn: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are unreliable and their use is discouraged.

error:will not proceed with blocklists.

I will have to resize partition 1 to start at 2048 to eliminate the use of blocklists.

Note You need to log in before you can comment on or make changes to this bug.