Bug 801148 - Tabindex on Providers -> Add Product (new) not correct
Tabindex on Providers -> Add Product (new) not correct
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 14:12 EST by Jason E. Rist
Modified: 2014-09-18 11:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason E. Rist 2012-03-07 14:12:53 EST
Description of problem:
When trying to tab through on the new product for providers, the tab never hits the button.


Version-Release number of selected component (if applicable):
git hash: 89360b4e37ff81ca9dafd29177df5163a03a3a03

How reproducible:
Always.

Steps to Reproduce:
1. Go to Custom Providers
2. Create a new custom provider (click "New Provider")
3. After that is created, it will slide back out, click the Add Product button
4. Start hitting tab to try to get to the Create button.
  
Actual results:
Does not tab to Create, ever, even after cycling through all tabbable items.

Expected results:
After hitting name and description, create should be 'highlighted' to be able to click.


Additional info:
Comment 1 Brad Buckingham 2012-03-13 15:52:09 EDT
commit - 40caa60ac09d1227e738e24b973f65b686b92be6

For this BZ, made changes for both the Add Product (subpanel) and Add Repository (subpanel).
Comment 3 Og Maciel 2012-03-19 12:02:04 EDT
Verified:
* candlepin-0.5.26-1.el6.noarch
* candlepin-tomcat6-0.5.26-1.el6.noarch
* katello-0.1.305-1.el6.noarch
* katello-all-0.1.305-1.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.4-1.el6.noarch
* katello-cli-0.1.105-1.el6.noarch
* katello-cli-common-0.1.105-1.el6.noarch
* katello-common-0.1.305-1.el6.noarch
* katello-configure-0.1.106-1.el6.noarch
* katello-glue-candlepin-0.1.305-1.el6.noarch
* katello-glue-foreman-0.1.305-1.el6.noarch
* katello-glue-pulp-0.1.305-1.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.9-1.el6.noarch
* pulp-1.0.0-5.el6.noarch
* pulp-common-1.0.0-5.el6.noarch
* pulp-selinux-server-1.0.0-5.el6.noarch
Comment 5 Mike McCune 2013-08-16 14:01:18 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.