Bug 801159 - Writing partition schem could be really slow, no feedback to the user
Writing partition schem could be really slow, no feedback to the user
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 14:36 EST by Kevin Raymond
Modified: 2012-03-08 12:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-08 09:47:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Raymond 2012-03-07 14:36:27 EST
While formating, and setting a LVM on big (1 Tera) hard drive disk, writing partition table, setting blocks, writing inode tables etc. could be *really* long. It tooks me more than 4hours!!! 

And the user has just the blue bar going from left to right and backward, without knowing what is happening. Only a fuzzy message is printed, like writing /dev/sda1 partition (for 3hours?!)

From the text console, I got things moving with several steps like
writing partition table: 1/5557
…
…
Writing inodes table: 1/5557
…
…

Showing the blocks ration will tell the user that the process is still going forward…

I were using F17 Alpha and ext4 format.
Comment 1 Chris Lumens 2012-03-08 09:47:01 EST
Screen scraping to display progress is almost always a bad idea, because it ties us to today's particular output format and means our progress reporting is going to break whenever the other program changes.  Sorry it took so long for you.  This is likely related to other disk slowness we've been hearing about.  I formatted a very large drive a few weeks back and it did not take anything near three hours.
Comment 2 Kevin Raymond 2012-03-08 12:39:54 EST
Ok, understood.
On the new design, I hope the user will know at least that things are moving :)

Note You need to log in before you can comment on or make changes to this bug.