Bug 801169 - SELinux is preventing /usr/bin/gtk-gnash from 'create' accesses on the dossier .gnash.
SELinux is preventing /usr/bin/gtk-gnash from 'create' accesses on the dossie...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6309fe08e558aeb63f9cb6869b0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 15:11 EST by Nicolas Chauvet (kwizart)
Modified: 2012-03-08 04:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-08 04:33:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2012-03-07 15:11:53 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc5.git3.1.fc17.x86_64
reason:         SELinux is preventing /usr/bin/gtk-gnash from 'create' accesses on the dossier .gnash.
time:           mer. 07 mars 2012 21:10:53 CET

description:
:SELinux is preventing /usr/bin/gtk-gnash from 'create' accesses on the dossier .gnash.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gtk-gnash should be allowed create access on the .gnash directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gtk-gnash /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                .gnash [ dir ]
:Source                        gtk-gnash
:Source Path                   /usr/bin/gtk-gnash
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           gnash-0.8.10-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.3.0-0.rc4.git1.4.fc17.x86_64 #1 SMP Wed Feb 22
:                              01:14:38 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    dim. 04 mars 2012 22:31:58 CET
:Last Seen                     dim. 04 mars 2012 22:31:58 CET
:Local ID                      059ccc0e-9d52-4322-8739-d57098a923fa
:
:Raw Audit Messages
:type=AVC msg=audit(1330896718.360:107): avc:  denied  { create } for  pid=21644 comm="gtk-gnash" name=".gnash" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1330896718.360:107): arch=x86_64 syscall=mkdir success=no exit=EACCES a0=1710658 a1=1c0 a2=2e a3=0 items=0 ppid=21618 pid=21644 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=gtk-gnash exe=/usr/bin/gtk-gnash subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gtk-gnash,mozilla_plugin_t,user_home_dir_t,dir,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-08 04:33:36 EST
The problem is your homedir is mislabeled

$ restorecon -R -v ~/

Then it should work correctly.

Note You need to log in before you can comment on or make changes to this bug.