Bug 801205 - minor device number change attempt fails
minor device number change attempt fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Petr Rockai
Cluster QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 17:53 EST by Corey Marthaler
Modified: 2012-06-20 11:02 EDT (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.95-2.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
: 838562 (view as bug list)
Environment:
Last Closed: 2012-06-20 11:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2012-03-07 17:53:36 EST
Description of problem:
This is a regression test failure on the first official 6.3 rpms.

 VOLUME MINOR DEV NUM CHANGE to 140 on taft-01
 taft-01: lvchange -ay -f -My --major 255 --minor 140 /dev/stripe_1_3131/stripe_1_31310

[root@taft-01 ~]# lvs -a -o +devices
 LV             VG            Attr     LSize   Devices
 stripe_1_31310 stripe_1_3131 -wi-a--- 904.00m /dev/sdh1(0)

[root@taft-01 ~]# lvchange -ay -f -My --major 255 --minor 140 /dev/stripe_1_3131/stripe_1_31310
  Error locking on node taft-01: Volume stripe_1_31310 (0:0) differs from already active device (253:2)
  Error locking on node taft-02: Volume stripe_1_31310 (0:0) differs from already active device (253:2)
  Error locking on node taft-04: Volume stripe_1_31310 (0:0) differs from already active device (253:2)
  Error locking on node taft-03: Volume stripe_1_31310 (0:0) differs from already active device (253:2)
  stripe_1_31310: reactivation failed

[root@taft-01 ~]# vgchange -an stripe_1_3131
  Error locking on node taft-01: Volume stripe_1_31310 (0:0) differs from already active device (253:2)
  Error locking on node taft-02: Volume stripe_1_31310 (0:0) differs from already active device (253:2)
  Error locking on node taft-04: Volume stripe_1_31310 (0:0) differs from already active device (253:2)
  Error locking on node taft-03: Volume stripe_1_31310 (0:0) differs from already active device (253:2)
  1 logical volume(s) in volume group "stripe_1_3131" now active


Version-Release number of selected component (if applicable):
2.6.32-220.4.2.el6.x86_64
lvm2-2.02.95-1.el6    BUILT: Tue Mar  6 10:00:33 CST 2012
lvm2-libs-2.02.95-1.el6    BUILT: Tue Mar  6 10:00:33 CST 2012
lvm2-cluster-2.02.95-1.el6    BUILT: Tue Mar  6 10:00:33 CST 2012
udev-147-2.40.el6    BUILT: Fri Sep 23 07:51:13 CDT 2011
device-mapper-1.02.74-1.el6    BUILT: Tue Mar  6 10:00:33 CST 2012
device-mapper-libs-1.02.74-1.el6    BUILT: Tue Mar  6 10:00:33 CST 2012
device-mapper-event-1.02.74-1.el6    BUILT: Tue Mar  6 10:00:33 CST 2012
device-mapper-event-libs-1.02.74-1.el6    BUILT: Tue Mar  6 10:00:33 CST 2012
cmirror-2.02.95-1.el6    BUILT: Tue Mar  6 10:00:33 CST 2012


How reproducible:
Everytime
Comment 4 Corey Marthaler 2012-03-08 18:28:30 EST
This happens in single machine mode as well.

[root@taft-01 ~]# lvchange -ay -f -My --major 255 --minor 66 /dev/mirror_1_9514/mirror_1_95140
  Volume mirror_1_95140 (0:0) differs from already active device (253:6)
  mirror_1_95140: deactivation failed
Comment 5 Alasdair Kergon 2012-03-15 21:46:14 EDT
Peter has found the cause of this - a command-line argument processing mistake I made when reusing major/minor.  (I tested that it still found the arguments OK after the change but forgot to confirm their values were still correct...)

Easily fixed.
Comment 7 Corey Marthaler 2012-03-16 15:24:39 EDT
Fix verfied in the latest rpms.

2.6.32-251.el6.x86_64

lvm2-2.02.95-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
lvm2-libs-2.02.95-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
lvm2-cluster-2.02.95-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
udev-147-2.40.el6    BUILT: Fri Sep 23 07:51:13 CDT 2011
device-mapper-1.02.74-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
device-mapper-libs-1.02.74-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
device-mapper-event-1.02.74-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
device-mapper-event-libs-1.02.74-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012
cmirror-2.02.95-2.el6    BUILT: Fri Mar 16 08:39:54 CDT 2012



VOLUME MINOR DEV NUM CHANGE to 197 on taft-01
taft-01: lvchange -ay -f -My --major 255 --minor 197 /dev/linear_2_957/linear_2_9570
verifying new minor num on taft-01
Comment 8 Peter Rajnoha 2012-04-12 09:41:03 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 10 errata-xmlrpc 2012-06-20 11:02:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0962.html

Note You need to log in before you can comment on or make changes to this bug.