Bug 801208 - tenant chooser doesn't work
Summary: tenant chooser doesn't work
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: python-django-horizon
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pádraig Brady
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-07 23:06 UTC by Cole Robinson
Modified: 2016-01-04 14:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-03 08:42:15 UTC
Type: ---


Attachments (Terms of Use)
keystone error (8.80 KB, text/plain)
2012-03-09 00:31 UTC, Derek Higgins
no flags Details

Description Cole Robinson 2012-03-07 23:06:00 UTC
python-django-horizon-2012.1-0.1.rc1.fc18.noarch

If a user has multiple associated tenants, the tenant chooser under the 'project' panel on the left hand side doesn't work. It might be a UI issue since the thing doesn't seem to react to clicking at all, and not a data issue on the other end.

Comment 1 Derek Higgins 2012-03-09 00:31:52 UTC
Created attachment 568779 [details]
keystone error

While using dashboard, the attached trace back is appearing in the keystone logfile

so keystone is returning a http 500 to dashboard (if this is the same problem)

Comment 2 Cole Robinson 2012-03-09 03:02:19 UTC
Derek, there's two parts I think. One is the issue you mention, I was hitting that too even with upstream and submitted a patch for it:

https://review.openstack.org/5088

The other seems to be a UI issue in that all fancy drop downs don't seem to be working at all. So even with my patch things don't work IIRC. Upstream has this UI bit fixed but I haven't bisected yet.

Comment 3 Cole Robinson 2012-04-15 21:26:06 UTC
That review was rejects, and essex was supposed to have a fix... but it didnt. So I submitted a new fix:

https://review.openstack.org/#/c/6579/

Comment 4 Cole Robinson 2012-05-29 23:36:56 UTC
That review expired, but it fixed things for me on F17, so might still be worth a push.

Also: https://bugs.launchpad.net/horizon/+bug/982595

Comment 5 Matthias Runge 2012-12-03 08:42:15 UTC
I have never seen those problems in current 2012.2.x versions. I guess it was fixed upstream.


Note You need to log in before you can comment on or make changes to this bug.