This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 801208 - tenant chooser doesn't work
tenant chooser doesn't work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: python-django-horizon (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 18:06 EST by Cole Robinson
Modified: 2016-01-04 09:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 03:42:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
keystone error (8.80 KB, text/plain)
2012-03-08 19:31 EST, Derek Higgins
no flags Details

  None (edit)
Description Cole Robinson 2012-03-07 18:06:00 EST
python-django-horizon-2012.1-0.1.rc1.fc18.noarch

If a user has multiple associated tenants, the tenant chooser under the 'project' panel on the left hand side doesn't work. It might be a UI issue since the thing doesn't seem to react to clicking at all, and not a data issue on the other end.
Comment 1 Derek Higgins 2012-03-08 19:31:52 EST
Created attachment 568779 [details]
keystone error

While using dashboard, the attached trace back is appearing in the keystone logfile

so keystone is returning a http 500 to dashboard (if this is the same problem)
Comment 2 Cole Robinson 2012-03-08 22:02:19 EST
Derek, there's two parts I think. One is the issue you mention, I was hitting that too even with upstream and submitted a patch for it:

https://review.openstack.org/5088

The other seems to be a UI issue in that all fancy drop downs don't seem to be working at all. So even with my patch things don't work IIRC. Upstream has this UI bit fixed but I haven't bisected yet.
Comment 3 Cole Robinson 2012-04-15 17:26:06 EDT
That review was rejects, and essex was supposed to have a fix... but it didnt. So I submitted a new fix:

https://review.openstack.org/#/c/6579/
Comment 4 Cole Robinson 2012-05-29 19:36:56 EDT
That review expired, but it fixed things for me on F17, so might still be worth a push.

Also: https://bugs.launchpad.net/horizon/+bug/982595
Comment 5 Matthias Runge 2012-12-03 03:42:15 EST
I have never seen those problems in current 2012.2.x versions. I guess it was fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.