Bug 801261 - documentation lists ovirt-* commands, but binaries are engine-*
documentation lists ovirt-* commands, but binaries are engine-*
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: doc-Installation-Guide (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.1
Assigned To: Stephen Gordon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 00:01 EST by Joe Pruett
Modified: 2012-08-09 04:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Pruett 2012-03-08 00:01:37 EST
Description of problem:
section 9.2 of the ovirt 3.0 installation guide references command ovirt-iso-uploader, but that binary doesn't exist.  engine-iso-uploader does.  appendix b lists ovirt-manage-domains, ovirt-config, ovirt-log-collector.  it looks like ovirt-manage-domains is also referenced in other sections.

Version-Release number of selected component (if applicable):
3.0

How reproducible:


Steps to Reproduce:
1. read docs
2. try to run command
3. fail
  
Actual results:
various 'command not found' errors

Expected results:


Additional info:
not sure if the rpm should be changed to match the docs or the docs to match the rpm.
Comment 1 Stephen Gordon 2012-03-08 14:25:14 EST
I am going to guess we are sticking to the command prefixes being 'engine-*', is that correct Itamar? The guides currently use 'ovirt-*', no doubt due to a misunderstanding on my part.
Comment 2 Keith Robertson 2012-06-05 06:33:09 EDT
AFAIU, the downstream commands will continue to be prefixed by "rhevm":

Example:
 - rhevm-log-collector
 - rhevm-iso-uploader
 - rhevm-image-uploader

The upstream counterparts are called: 
 - ovirt-log-collector
 - ovirt-iso-uploader
 - ovirt-image-uploader

I can rename the upstream ones to whatever we want but, I would be hesitant to rename the downstream versions because people are familiar with that convention now.

For the documentation guys:
 The upstream and downstream projects all have manpages that are correct, AFAIK.  They list config files and such that each tool reads.  Shoot me an email if you have problems finding the manpages (use the latest from the git repos)

Cheers
Comment 3 Keith Robertson 2012-06-05 10:13:43 EDT
OK, here's the deal.  You must be getting .rpms from [1].  Those RPMs were created around the time that there was a bunch of name changing going on.  I think we ultimately decided that upstream RPMs would be prefixed with "ovirt-*" and the actual tools would be  prefixed with "engine-*".  I have made changes to all of my tools pursuant to that [3].

Cheers,
Keith


[1] http://www.ovirt.org/releases/stable/fedora/16/

[2]
[keith@whiplash junk]$ rpm2cpio ../ovirt-engine-log-collector-3.0.0_0001-1.6.fc16.x86_64.rpm | cpio -idmv
./etc/ovirt-engine/logcollector.conf
./usr/bin/engine-log-collector
./usr/lib/python2.7/site-packages/sos/plugins/engine.py
./usr/lib/python2.7/site-packages/sos/plugins/jboss.py
./usr/lib/python2.7/site-packages/sos/plugins/postgresql.py
./usr/share/man/man8/engine-log-collector.8.gz
./usr/share/ovirt-engine/log-collector
./usr/share/ovirt-engine/log-collector/logcollector.py
./usr/share/ovirt-engine/log-collector/schemas
./usr/share/ovirt-engine/log-collector/schemas/__init__.py
./usr/share/ovirt-engine/log-collector/schemas/api.py
./usr/share/ovirt-engine/log-collector/schemas/hypervisors.py

[3]
[keith@whiplash workspace-public-projects]$ grep _bindir ovirt-log-collector/*.spec ovirt-image-uploader/*.spec ovirt-iso-uploader/*.spec*
ovirt-log-collector/ovirt-log-collector.spec:%{_bindir}/engine-log-collector
ovirt-image-uploader/ovirt-image-uploader.spec:%{_bindir}/engine-image-uploader
ovirt-iso-uploader/ovirt-iso-uploader.spec.in:%{_bindir}/engine-iso-uploader
Comment 4 Stephen Gordon 2012-06-07 15:35:30 EDT
http://gerrit.ovirt.org/5146
Comment 5 Justin Clift 2012-06-19 21:53:31 EDT
Found new occurrences of the problem in the Install doc.  Appendix B:

  B.2. Configuration Tool
    During installation, only a subset of oVirt Engine's configuration
    settings are modified from their  defaults. You make further
    changes with the included configuration tool, ovirt-config.

The "ovirt-config" there (and mentioned elsewhere) should be "engine-config".

Actual path to the binary is /usr/bin/engine-config, if that helps. :)
Comment 6 Itamar Heim 2012-08-09 04:00:33 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/
Comment 7 Itamar Heim 2012-08-09 04:03:07 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.