Bug 801301 - 'rhc domain' command should get the help page when executing it directly
'rhc domain' command should get the help page when executing it directly
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 03:49 EST by Meng Bo
Modified: 2013-03-13 00:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-06 02:44:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-03-08 03:49:22 EST
Description of problem:
when executing 'rhc domain' command, it should get the command help page like other commands.

Version-Release number of selected component (if applicable):
rhc-0.88.1-1.el6_2.noarch

How reproducible:
always

Steps to Reproduce:
1.install latest rhc client
2.run 'rhc domain' command
3.
  
Actual results:
'rhc domain' command get the domain information just like 'rhc domain show'

Expected results:
when executing the command 'rhc domain' without other args, it should print the help page for the command.

Additional info:
[mengbo@localhost ~]$ rhc domain
Password: 

User Info
=========
Namespace: bmeng1dev6
  RHLogin: bmeng+1@redhat.com


Application Info
================
No applications found.  You can use 'rhc app create' to create new applications.




[mengbo@localhost ~]$ rhc sshkey
Missing or invalid command!

Usage: rhc sshkey (<command> | --help) [<args>]
Manage multiple keys for the registered rhcloud user.

List of commands
  list                           Display all the SSH keys for the user account
  add                            Add SSH key to the user account
  update                         Update SSH key for the user account
  remove                         Remove SSH key from the user account

List of arguments
  -l|--rhlogin      rhlogin      Red Hat login (RHN or OpenShift login with OpenShift Express access) (Default: bmeng+1@redhat.com)
  -p|--password     password     RHLogin password (optional, will prompt)
  -i|--identifier   key-name     User-specified identifier for the key
  -k|--ssh          key-filepath SSH public key filepath 
  -d|--debug                     Print Debug info
  -h|--help                      Show Usage info
  --config          path         Path of alternate config file
  --timeout         #            Timeout, in seconds, for connection
Comment 1 John (J5) Palmieri 2012-04-05 17:55:37 EDT
# if the user just enters "rhc domain", don't throw an error
# let it be handled by the "rhc domain show" command

This seems to be intentional.  Any good reason to fix this now?
Comment 2 Meng Bo 2012-04-06 02:44:26 EDT
close this bug since this is by design.

Note You need to log in before you can comment on or make changes to this bug.