Bug 801351 - crm_report -v does not increase verbosity
crm_report -v does not increase verbosity
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Andrew Beekhof
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 05:45 EST by Jaroslav Kortus
Modified: 2016-04-26 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: pacemaker-1.1.7-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: Documentation typo Consequence: The documented meaning for the short form of -V and -v were swapped Fix: Fix typo
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:48:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Kortus 2012-03-08 05:45:15 EST
Description of problem:
crm_report -v does not increase verbosity as the -h and man page suggest.


Version-Release number of selected component (if applicable):
pacemaker-1.1.7-2.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. crm_report -v
2.
3.
  
Actual results:
probably prints version

Expected results:
one of:
 * -v option documented as version information
 * more verbose output

Additional info:
Comment 2 Andrew Beekhof 2012-03-13 07:44:56 EDT
A related patch has been committed upstream:
  https://github.com/beekhof/pacemaker/commit/a68a43c

with subject:

   Low: Tools: Bug rhbz#801351 - Fix crm_report help text

Further details (if any):
Comment 6 Jaroslav Kortus 2012-04-05 11:27:43 EDT
pacemaker-1.1.7-5.el6.x86_64

man page is now correct, help text is correct, -V increases verbosity.
Comment 7 Andrew Beekhof 2012-05-08 07:47:07 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Documentation typo
Consequence: The documented meaning for the short form of -V and -v were swapped 
Fix: Fix typo
Comment 9 errata-xmlrpc 2012-06-20 09:48:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0846.html

Note You need to log in before you can comment on or make changes to this bug.