This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 801370 - Network Manager won't stay stopped
Network Manager won't stay stopped
Status: CLOSED DUPLICATE of bug 815243
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 06:34 EST by Steve Hill
Modified: 2012-09-06 08:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 08:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2012-03-08 06:34:02 EST
Description of problem:
When diagnosing network problems it is often useful to temporarily turn NetworkManager off.  This allows for quick manual reconfiguration of network interfaces, running applications such as Kismet, etc. without having to completely reconfigure NetworkManager itself.

The obvious way to do this is "service NetworkManager stop", which does indeed stop Network Manager as expected.  Unfortunately, within a few seconds, something starts NetworkManager again.  This violates the principle of least surprise - when a service is explicitly manually stopped, it is expected to stay stopped until the user explicitly starts it again (or reboots).  There is no obvious indication of what is responsible for restarting it.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.2-1.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. service NetworkManager stop
2. Wait a few seconds
3. NetworkManager spontaneously starts again.
  
Actual results:
Network Manager spontaneously starts after the user has explicitly stopped the service.

Expected results:
Services that were manually stopped by the user should not spontaneously start.

Additional info:
Comment 1 Jirka Klimes 2012-09-06 08:27:35 EDT
I agree that it is annoying when NetworkManager is unexpectedly D-Bus activated.
For now you should use "systemctl disable NetworkManager.service" to prevent NetworkManager from restarting.

There is a quite long discussion about that in bug #815243

*** This bug has been marked as a duplicate of bug 815243 ***

Note You need to log in before you can comment on or make changes to this bug.