Bug 801379 - It's not possible to create custom layout in text mode installation
It's not possible to create custom layout in text mode installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-08 07:04 EST by Petr Schindler
Modified: 2012-04-02 20:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-08 09:38:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of partitioning menu (8.62 KB, image/png)
2012-03-08 07:04 EST, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2012-03-08 07:04:53 EST
Created attachment 568609 [details]
screenshot of partitioning menu

Description of problem:
There is no possibility to make any custom layout when installing with text interface. It's impossible to encrypt disk or to choose if LVM will be used. There are lot of cases when user needs to make his own layout e.g. if he needs to encrypt disk.

You can find screenshot of partitioning menu in attachment.

Version-Release number of selected component (if applicable):
anaconda-17.12

How reproducible:
100%

Steps to Reproduce:
1. Boot from DVD.iso (e.g. 17-Beta.TC1) and choose to install
2. Proceed to the partitioning menu following default options
3. Try to make a custom layout
  
Actual results:
There is no option to make custom layout

Expected results:
User should have possibility to make his own layout.

Additional info:
I propose this bug as Beta blocker. Text interface is supported by anaconda and it should meet all criteria. This bug violates Alpha criterion "The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption or LVM enabled"
Comment 1 Chris Lumens 2012-03-08 09:38:17 EST
This is by design - the current text interface is simply too limited to have the space we need for custom partitioning.  Please use either a graphical installation or VNC.

The test criteria need to be changed.  The text interface has been in this limited mode for several releases now, and everyone should be used to it.  We will not be doing anything about this.
Comment 2 Felix Miata 2012-04-02 20:15:44 EDT
Ought to be able to at least specify which existing partition will be used for /, even if it means designating it on cmdline of installation startup.

Note You need to log in before you can comment on or make changes to this bug.