Bug 801380 - Reverse zone is removed while deleting replica agreement.
Reverse zone is removed while deleting replica agreement.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 07:06 EST by Gowrishankar Rajaiyan
Modified: 2012-06-20 09:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-2.2.0-6.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:20:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-03-08 07:06:47 EST
Description of problem:


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
MASTER:
1. ipa-server-install --setup-dns
2. ipa-replica-prepare --ip-address=10.65.201.101 $REPLICA

REPLICA:
1. ipa-replica-install -U -w Secret123 -p Secret123 /var/lib/ipa/replica-info-$REPLICA.gpg  --setup-dns --no-forwarders

MASTER:
1. ipa dnszone-find (make sure forward and reverse zone both exist)
2. ipa-replica-manage del $REPLICA
Deleting a master is irreversible.
To reconnect to the remote master you will need to prepare a new replica file
and re-install.
Continue to delete? [no]: yes
Deleted replication agreement from '$MASTER' to '$REPLICA'
3. ipa dnszone-find

Actual results: Reverse zone is removed while deleting replication agreement.

[root@primenova ~]# ipa dnszone-find
  Zone name: lab.eng.pnq.redhat.com
  Authoritative nameserver: primenova.lab.eng.pnq.redhat.com.
  Administrator e-mail address: hostmaster.lab.eng.pnq.redhat.com.
  SOA serial: 2013
  SOA refresh: 3600
  SOA retry: 900
  SOA expire: 1209
  SOA minimum: 3600
  Active zone: TRUE
  Allow query: any;
  Allow transfer: none;
----------------------------
Number of entries returned 1
----------------------------

Expected results: Reverse zone itself should not be removed. 

Additional info:
Comment 2 Martin Kosek 2012-03-08 07:54:06 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2503
Comment 7 Gowrishankar Rajaiyan 2012-04-16 03:20:16 EDT
[root@celeno ~]# ipa-replica-manage del ivanova.testrelm.com
Deleting a master is irreversible.
To reconnect to the remote master you will need to prepare a new replica file
and re-install.
Continue to delete? [no]: yes
Deleted replication agreement from 'celeno.testrelm.com' to 'ivanova.testrelm.com'
[root@celeno ~]# 
:: [   PASS   ] :: Running 'cat /tmp/replicaDel.out'
:: [   PASS   ] :: Running 'replicaDel root 10.16.96.69 "ipa-replica-manage del ivanova.testrelm.com" yes'
[root@celeno ~]# 
:: [18:23:37] ::  verifies https://bugzilla.redhat.com/show_bug.cgi?id=801380
:: [   PASS   ] :: Running '/usr/bin/expect /tmp/remote_exec.exp >> /tmp/remote_exec.out 2>&1'
...
:: [   PASS   ] :: Running 'cat /tmp/remote_exec.exp'
spawn ssh -l root 10.16.96.69
Last login: Tue Apr 10 18:22:55 2012 from ivanova.testrelm.com
[root@celeno ~]# ipa dnszone-find
  Zone name: 96.16.10.in-addr.arpa.
  Authoritative nameserver: celeno.testrelm.com.
  Administrator e-mail address: hostmaster.96.16.10.in-addr.arpa.
  SOA serial: 2012041001
  SOA refresh: 3600
  SOA retry: 900
  SOA expire: 1209600
  SOA minimum: 3600
  Active zone: TRUE
  Allow query: any;
  Allow transfer: none;

  Zone name: testrelm.com
  Authoritative nameserver: celeno.testrelm.com.
  Administrator e-mail address: hostmaster.testrelm.com.
  SOA serial: 2012041003
  SOA refresh: 3600
  SOA retry: 900
  SOA expire: 1209600
  SOA minimum: 3600
  Active zone: TRUE
  Allow query: any;
  Allow transfer: none;
----------------------------
Number of entries returned 2
----------------------------
[root@celeno ~]# :: [   PASS   ] :: Running 'cat /tmp/remote_exec.out'
:: [   PASS   ] :: Running 'remoteExec root 10.16.96.69 redhat "ipa dnszone-find"'
  Zone name: 96.16.10.in-addr.arpa.
  Administrator e-mail address: hostmaster.96.16.10.in-addr.arpa.
:: [   PASS   ] :: Running 'egrep 10.in-addr.arpa. /tmp/remote_exec.out'


Verified: ipa-server-2.2.0-9.el6.x86_64
Comment 9 Martin Kosek 2012-04-24 09:44:00 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 11 errata-xmlrpc 2012-06-20 09:20:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.