Bug 801436 - Support for xinput2 disabled in wine build
Support for xinput2 disabled in wine build
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 795147 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 09:31 EST by Oleg Girko
Modified: 2012-05-05 12:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: wine-1.5.2-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 16:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Girko 2012-03-08 09:31:28 EST
Description of problem:

Some time ago wine started using xinput2 extension instead of mouse wrapping for better mouse handling inside games and other fullscreen applications.
Unfortunately, xinput2 support had some issues, so it was disabled in wine build 1.3.25-1 in Fedora.

Now wine 1.4 is released and it has much better and stable xinput2 support. It's time to re-enable xinput2 support in wine builds for Fedora.

Without xinput2, several popular games are unplayable or barely playable inder wine, including STALKER: Call of Pripyat, Metro 2033, Operation Flashpoint: Dragon Rising and many others.

I use wine built with xinput2 support since version 1.3.37 and there were no problems with it.

Version-Release number of selected component (if applicable):
1.3.37-1
1.4-1

How reproducible:
Easily producible with several popular games.

Steps to Reproduce:
1. Install Operation Flashpoint: Dragon Rising inder wine using Steam.
2. Install d3dx9_36 and dinput8 DLLs using winetricks.
3. Start the game.
  
Actual results:
You can't turn around in the game. Hence, game is unplayable.

Expected results:
You should be able to turn around in the game.

Additional info:
Everything works fine with wine build using the same spec file with "--without-xinput2" parameter removed from "%configure" arguments.
Comment 1 Rodrigo Araujo 2012-04-01 19:57:24 EDT
I can confirm this still occurs in the recent wine 1.5.0-2 update, which incidentally, installed itself over the 1.4-1 version I had rebuilt without the non-sensical "--without-xinput2" parameter.

After rebuilding it again myself with "--without-xinput2" parameter removed from "%configure" arguments, wine is working correctly again with games (tested with Mass Effect 3).
Comment 2 Jason Montleon 2012-04-16 21:58:51 EDT
with 1.4 / 1.5.1 on Fedora 16 UT3 does not work correctly without xinput2 either. You either have to deal with navigating the menus with the keyboard or have the mouse broken in game without it.
Comment 3 Rodrigo Araujo 2012-04-22 17:00:08 EDT
The fix is simple for fc15 onwards: just remove --without-xinput2 from the spec file and rebuild, as described above.

AFAIK xinput2 support in wine has been stable for a while now, and it only is activated if you select the option to capture the mouse in full screen applications.

Given how easy it is to fix, it's strange that it hasn't been already. Recently there was another update to the package that didn't include this fix and if you had (like me) rebuilt the previous version, this update has overwritten it.

Is it possible to do that on the next update? Or is there a strong reason against it and people who need it will just have to exclude wine-* from yum updates?

Best regards.
Comment 4 Andreas Bierfert 2012-04-23 10:42:34 EDT
I have enabled this last week with 1.5.2-2 build. However this will need some further testing as this will fix some issues but leave other people with bugs.
Comment 5 Fedora Update System 2012-04-23 11:38:55 EDT
wine-1.5.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wine-1.5.2-2.fc16
Comment 6 Fedora Update System 2012-04-23 11:39:05 EDT
wine-1.5.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wine-1.5.2-2.fc17
Comment 7 Fedora Update System 2012-04-23 11:39:15 EDT
wine-1.5.2-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/wine-1.5.2-2.fc15
Comment 8 Rodrigo Araujo 2012-04-23 17:20:27 EDT
Thanks!

I just downloaded the built RPMs for fc16 and freshened them (i686, although it's a 64 bit system). For now all seems well (can play Mass Effect 3).

I'll report back here should I find anything bad. Best regards.
Comment 9 Fedora Update System 2012-04-23 23:18:32 EDT
Package wine-1.5.2-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-1.5.2-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6477/wine-1.5.2-2.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-05-02 16:52:13 EDT
wine-1.5.2-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-05-03 03:26:45 EDT
wine-1.5.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-05-03 03:31:46 EDT
wine-1.5.2-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Göran Uddeborg 2012-05-05 12:56:12 EDT
*** Bug 795147 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.