Bug 80148 - sndconfig works better than new replacement
sndconfig works better than new replacement
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-soundcard (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-20 12:51 EST by Petri T. Koistinen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-22 12:02:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petri T. Koistinen 2002-12-20 12:51:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have C-Media Electronics Inc CM8738 soundcard that is integrated on ASUS
A7V333 motherboard. It seems that redhat-config-soundcard is able to detect this
card, but it will not play test sound.

If I run old sndconfig tool it will find this soundcard and it is able play test
sound and system work fine after using it. Even redhat-config-soundcard "Play
test sound" button works after sndconfig has been used to configure soundcard.

So this new soundcard detection system should be working at least as good as old
one, before you are going to remove sndconfig.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to install C-Media Electronics Inc|CM8738 soundcard

Actual Results:  Installation was not successful with
/usr/bin/redhat-config-soundcard, but deprecated /usr/sbin/sndconfig did the job.

Expected Results:  Replacement should work as good as old configuration tool

Additional info:

Severity is still low, as long as sndconfig is available. My hardware is quite
up to date, so don't blame me for using obsolete hardware.
Comment 1 Brent Fox 2002-12-22 11:05:27 EST
Hmm, that is strange.  We aren't removing sndconfig until
redhat-config-soundcard can support ISA cards, which isn't going to happen for
this release.  

redhat-config-soundcard-1.0.2-2 out of Rawhide may fix this problem.  I've done
a lot of work so that redhat-config-soundcard sets up /etc/modules.conf properly
and reloads the modules properly.  

If you want to test this, install the new version out of Rawhide.  Then, remove
all the lines related to "sound-slot" from /etc/modules.  Then run
redhat-config-soundcard and click "Play test sound".  

I would test this myself, but I don't have your exact soundcard.
Comment 2 Petri T. Koistinen 2002-12-22 11:39:42 EST
Yep, I removed those things from /etc/modules.conf, rebooted and made sure with
xmms that there where not soundcard driver module loaded. Started the new
program installed from Rawhide and seems to be working. Thank you!

How about releasing errata?
Comment 3 Brent Fox 2002-12-22 12:02:10 EST
I would like to, but I doubt that it will happen.  Most of QA's time is spent on
the Advanced Server errata and is pretty much limited to security errata.  I'll
just point people to Rawhide for now and the next version will be out before too
long.  :)  

I'm glad to know that redhat-config-soundcard-1.0.2-2 fixes the problem you were
seeing.  Thanks for your report.  Closing as 'Rawhide'

Note You need to log in before you can comment on or make changes to this bug.