Bug 801493 - Please create policy for pacemaker (runs as initrc_t)
Please create policy for pacemaker (runs as initrc_t)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330 768522 848613 915151 1003613
  Show dependency treegraph
 
Reported: 2012-03-08 11:27 EST by Jaroslav Kortus
Modified: 2014-06-17 10:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-160.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 848613 915151 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:34:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Working policy module (2.24 KB, application/x-gzip)
2013-01-04 06:23 EST, Vladislav Bogdanov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0314 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2013-02-20 15:35:01 EST

  None (edit)
Description Jaroslav Kortus 2012-03-08 11:27:47 EST
Description of problem:
pacemaker (possible rgmanager replacement) does not have any policy defined and starts in initrc_t.

Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-139.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. service pacemaker start
2.
3.
  
Actual results:
wrong context

Expected results:
pacemaker's own context for all daemons with proper permissions (TBD)

Additional info:
Comment 2 Miroslav Grepl 2012-03-09 05:24:59 EST
Jaroslav,
so is it going to work as rgmanager? Probably you could try to treat it with rgmanager using

$ chcon -t rgmanager_exec_t /usr/sbin/pacemakerd

We added pacemaker policy to Fedora but if this policy ends up unconfined as rgmanager we will treat it with rgmanager.
Comment 7 RHEL Product and Program Management 2012-07-10 04:20:21 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 21:55:22 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 15 Andrew Beekhof 2012-12-20 20:29:24 EST
Stupid question, have we tried it with some cluster services (like an IP address) configured?
Comment 17 Vladislav Bogdanov 2013-01-04 06:23:57 EST
Created attachment 672367 [details]
Working policy module

This one can be considered as a starting point, because I use it with corosync2 but not with cman.
Please look at thread
http://comments.gmane.org/gmane.linux.highavailability.pacemaker/15817
for more details.
Comment 18 errata-xmlrpc 2013-02-21 03:34:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html
Comment 19 Andrew Beekhof 2013-02-22 02:43:58 EST
How come this got closed?
Can we get some feedback on the patch in comment #17 please?

A cluster that can't control resources isn't very useful.
Do we need to clone this into 6.4 or something?
Comment 20 Miroslav Grepl 2013-02-22 04:24:21 EST
This bug was about a new policy which we added. Please open a new one. Thank you.

Note You need to log in before you can comment on or make changes to this bug.