Bug 801546 - SIGSEGV @vgaHW.c:1076 (hwp->writeDacMask points to NULL)
SIGSEGV @vgaHW.c:1076 (hwp->writeDacMask points to NULL)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 803450 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 14:41 EST by Damian Wrobel
Modified: 2012-04-11 23:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: xorg-x11-drv-vmware-12.0.1-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 23:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb session dump (4.73 KB, text/plain)
2012-03-08 14:42 EST, Damian Wrobel
no flags Details
Xorg.0.log (8.92 KB, text/plain)
2012-03-08 14:42 EST, Damian Wrobel
no flags Details
gdb session dump (xorg-x11-drv-vmware-11.0.3-14.fc17.i686 version) (5.69 KB, text/plain)
2012-03-23 04:01 EDT, Damian Wrobel
no flags Details
Xorg.0.log (xorg-x11-drv-vmware-11.0.3-14.fc17.i686 version) (8.31 KB, text/plain)
2012-03-23 04:01 EDT, Damian Wrobel
no flags Details
rpm -qa "xorg\*" | sort - output (1.36 KB, text/plain)
2012-03-23 04:03 EDT, Damian Wrobel
no flags Details

  None (edit)
Description Damian Wrobel 2012-03-08 14:41:00 EST
Description of problem:
Fedora 17 i686 livecd crashes (Xorg) while running in VMware Player

Version-Release number of selected component (if applicable):
Live image build from the latest sources as of: Thu Mar  8 19:56:00 CET 2012

In particular xorg version: xorg-x11-server-1.11.99.901-6.20120124.fc17

How reproducible:
100% (at least on my machine)

Steps to Reproduce:
1. Launch Fedora 17 i686 livecd image in VMware Player running on Fedora 16.
  
Actual results:
No graphical user interface is available

Expected results:
Image should boot successfully.

Additional info:
It looks that hwp->writeDacMask points to NULL:

#12 0x0092fef3 in vgaHWSaveColormap (scrninfp=scrninfp@entry=0x99d0ba8, save=save@entry=0x99d18bc) at vgaHW.c:1076
1076	    hwp->writeDacMask(hwp, 0xFF);
$4 = (vgaHWWriteProcPtr) 0
Comment 1 Damian Wrobel 2012-03-08 14:42:05 EST
Created attachment 568733 [details]
gdb session dump
Comment 2 Damian Wrobel 2012-03-08 14:42:55 EST
Created attachment 568734 [details]
Xorg.0.log
Comment 3 Fedora Update System 2012-03-12 11:03:05 EDT
xorg-x11-drv-vmware-11.0.3-14.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-vmware-11.0.3-14.fc17
Comment 4 Fedora Update System 2012-03-12 15:08:43 EDT
Package xorg-x11-drv-vmware-11.0.3-14.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-vmware-11.0.3-14.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3630/xorg-x11-drv-vmware-11.0.3-14.fc17
then log in and leave karma (feedback).
Comment 5 Adam Jackson 2012-03-15 10:03:28 EDT
*** Bug 803450 has been marked as a duplicate of this bug. ***
Comment 6 Damian Wrobel 2012-03-23 03:59:43 EDT
I'm still observing the same issue while upgrading to the xorg-x11-drv-vmware-11.0.3-14.fc17 version.
Comment 7 Damian Wrobel 2012-03-23 04:01:09 EDT
Created attachment 572187 [details]
gdb session dump (xorg-x11-drv-vmware-11.0.3-14.fc17.i686 version)
Comment 8 Damian Wrobel 2012-03-23 04:01:59 EDT
Created attachment 572188 [details]
Xorg.0.log (xorg-x11-drv-vmware-11.0.3-14.fc17.i686 version)
Comment 9 Damian Wrobel 2012-03-23 04:03:11 EDT
Created attachment 572189 [details]
rpm -qa "xorg\*" | sort  - output
Comment 10 Espen Stefansen 2012-03-28 05:34:14 EDT
This happens on x86_64 platform as well.
Comment 11 Fedora Update System 2012-03-30 03:12:08 EDT
xorg-x11-drv-vmware-12.0.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-vmware-12.0.1-2.fc17
Comment 12 Fedora Update System 2012-03-30 13:59:08 EDT
Package xorg-x11-drv-vmware-12.0.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-vmware-12.0.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4925/xorg-x11-drv-vmware-12.0.1-2.fc17
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-04-11 23:36:23 EDT
xorg-x11-drv-vmware-12.0.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.