Bug 801552 - SYSFONT=True causes error message during boot
SYSFONT=True causes error message during boot
Status: CLOSED DUPLICATE of bug 799401
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 15:16 EST by Jaroslaw Gorny
Modified: 2012-06-26 06:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 09:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Gorny 2012-03-08 15:16:46 EST
Description of problem:

/etc/default/grub in GRUB_CMDLINE_LINUX= directive contains an entry "SYSFONT=True"

Such a font does not exist (at least in 'Default' installation of F17 Alpha2 + all updates until today). This causes error during boot.


Version-Release number of selected component (if applicable):
grub2-1.99-14.fc17.i686

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 17
2. Boot system

  
Actual results:
Error "Cannot find font True" appears during early boot stage.

Expected results:
No error. Either this entry should be disabled, or changed, or font installed by default.
Comment 1 Mads Kiilerich 2012-04-17 18:38:23 EDT
That file has been generated by anaconda ... and it did apparently for some reason put a bad value there.

Please attach the whole /etc/default/grub file and the anaconda log.

How did you install? Manually with an install media?
Comment 2 Chris Lumens 2012-04-18 09:35:43 EDT

*** This bug has been marked as a duplicate of bug 799401 ***
Comment 3 Nguha Huirama-Patuwai 2012-06-26 06:26:52 EDT
Nguha

How do you kill this bug?  How can you access dracut and stop it from crashing?

To date, I am overwriting (replacing the word 'true' with DejaVu Sans.  Dracut needs to recognise this change......still trying to fix this....Dracut also tells me that a certain file does not exist....I am trying to download Dracut so that I can see how it works...... June 28 2012

Note You need to log in before you can comment on or make changes to this bug.