Bug 801657 - Can not start virt-who service.
Can not start virt-who service.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 00:50 EST by Hui Wang
Modified: 2016-11-30 19:30 EST (History)
3 users (show)

See Also:
Fixed In Version: virt-who-0.6-2.el6
Doc Type: Bug Fix
Doc Text:
Cause: Dependency on python-suds was missing. Consequence: virt-who refuses to start Fix: add Requires: python-suds to specfile Result: virt-who starts correctly
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:14:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2012-03-09 00:50:48 EST
Description of problem:
The virt-who can't be started due to no suds module.

Version-Release number of selected component (if applicable):
virt-who-0.6-1.el6.noarch
subscription-manager-firstboot-0.99.9-1.el6.x86_64
subscription-manager-0.99.9-1.el6.x86_64
subscription-manager-gnome-0.99.9-1.el6.x86_64
katello-headpin-all-0.1.141-1.el6.noarch
katello-headpin-0.1.141-1.el6.noarch
candlepin-0.5.23-1.el6.noarch
candlepin-tomcat6-0.5.23-1.el6.noarch
thumbslug-0.0.21-1.el6.noarch

How reproducible:
always

Steps to Reproduce:

1.Install rhel6.3
2.Register the rhel6.3 to SAM
3.Restart the virt-who 
#service virt-who restart

Stopping virt-who:                                         [FAILED]
Starting virt-who: Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 27, in <module>
    from vsphere import VSphere
  File "/usr/share/virt-who/vsphere.py", line 3, in <module>
    import suds
ImportError: No module named suds
                                                           [FAILED]
  
Actual results:
The virt-who can't be started.

Expected results:
The virt-who can be started successfully.

Additional info:
Comment 1 Hui Wang 2012-03-09 00:57:24 EST
If install the python-suds package, it will can be started.
Comment 3 Radek Novacek 2012-03-09 02:27:24 EST
"Requires: python-suds" is missing in the specfile. This is an easy fix.
Comment 4 Radek Novacek 2012-03-12 04:05:49 EDT
This bug has been fixed in virt-who-0.6-2.el6.
Comment 6 Hui Wang 2012-03-15 01:29:54 EDT
Verified the issue, the result is PASS.

Version:
virt-who-0.6-2.el6.noarch
subscription-manager-0.99.9-1.el6.x86_64
katello-headpin-all-0.1.142-1.el6.noarch
katello-headpin-0.1.142-1.el6.noarch
candlepin-0.5.24-1.el6.noarch
candlepin-tomcat6-0.5.24-1.el6.noarch
thumbslug-0.0.21-1.el6.noarch

1.Install RHEL6.3-20120313.2
2.Register the rhel6.3 to SAM
3.Restart the virt-who 
# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who: Virt-who is running in libvirt mode
Starting infinite loop with 3600 seconds interval and event handling
                                                           [  OK  ]
[root@host208 ~]# Sending update to updateConsumer: []
Comment 7 Radek Novacek 2012-05-02 02:23:12 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Dependency on python-suds was missing.

Consequence: virt-who refuses to start

Fix: add Requires: python-suds to specfile

Result: virt-who starts correctly
Comment 8 errata-xmlrpc 2012-06-20 10:14:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0900.html

Note You need to log in before you can comment on or make changes to this bug.