Bug 801750 - New kernel disconnects my wifi after a few minutes after connection
New kernel disconnects my wifi after a few minutes after connection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 06:36 EST by Martí­n Marqués
Modified: 2012-04-08 20:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-08 20:57:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martí­n Marqués 2012-03-09 06:36:05 EST
Description of problem:

After updating the kernel on my laptop with F15 wifi (Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express)) connects all right, but after a few minutes it disconnects and starts to connect once again, failing.

Moving back to the old 2.6.42.7 kernel solves the problem.

My connection is with WPA2. Haven't checked without encryption.

Version-Release number of selected component (if applicable):

kernel-2.6.42.9-1.fc15

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

lspci -vv for my atheros wifi chip

04:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
        Subsystem: Wistron NeWeb Corp. Device 30af
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at ff600000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2- AuxCurrent=375mA PME(D0+,D1+,D2-,D3hot+,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
                Address: 00000000  Data: 0000
        Capabilities: [60] Express (v2) Legacy Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Not Supported, TimeoutDis+
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
                LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -6dB
        Capabilities: [100 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
        Capabilities: [140 v1] Virtual Channel
                Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
                Arb:    Fixed- WRR32- WRR64- WRR128-
                Ctrl:   ArbSelect=Fixed
                Status: InProgress-
                VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=01
                        Status: NegoPending- InProgress-
        Capabilities: [160 v1] Device Serial Number 00-15-17-ff-ff-24-14-12
        Capabilities: [170 v1] Power Budgeting <?>
        Kernel driver in use: ath9k
        Kernel modules: ath9k
Comment 1 John W. Linville 2012-03-09 10:53:37 EST
Please attach the output of 'dmesg' after the problem starts...thanks!
Comment 2 Martí­n Marqués 2012-03-13 21:19:24 EDT
Just after I get disconnected these lines are added to dmesg.

[  125.668395] cfg80211: Calling CRDA to update world regulatory domain
[  125.750197] cfg80211: World regulatory domain updated:
[  125.750201] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  125.750204] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  125.750207] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  125.750209] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  125.750211] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  125.750213] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  127.172912] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 1)
[  127.372064] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 2)
[  127.572183] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 3)
[  127.772083] wlan0: authentication with f4:ec:38:ea:4e:2e timed out
[  134.176624] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 1)
[  134.376173] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 2)
[  134.576027] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 3)
[  134.776209] wlan0: authentication with f4:ec:38:ea:4e:2e timed out
[  141.196767] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 1)
[  141.396025] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 2)
[  141.596018] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 3)
[  141.796029] wlan0: authentication with f4:ec:38:ea:4e:2e timed out
[  143.211568] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 1)
[  143.411093] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 2)
[  143.611143] wlan0: authenticate with f4:ec:38:ea:4e:2e (try 3)
[  143.811054] wlan0: authentication with f4:ec:38:ea:4e:2e timed out
Comment 3 Martí­n Marqués 2012-03-14 07:39:02 EDT
Also, the issue is not related to WPA. Same thing happened with an open wifi router (connection with no authentification or encryption.)
Comment 4 Martí­n Marqués 2012-04-08 20:57:33 EDT
Kernel 2.6.42.12-1 seems to work OK. Don't know what changed, but everything is allright.

Note You need to log in before you can comment on or make changes to this bug.