Bug 801782 - Updates notification doesn't show up
Updates notification doesn't show up
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-09 08:46 EST by Petr Schindler
Modified: 2012-03-19 19:43 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 19:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2012-03-09 08:46:19 EST
Description of problem:
After clean installation I waited long time (2 hours) and no updates notification showed up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Petr Schindler 2012-03-09 08:55:42 EST
Sorry I sent it by mistake.

Version-Release number of selected component (if applicable):
PackageKit-0.7.3-1.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Install f17 (Beta.TC1) and boot
2. Wait for updates
3.

Actual results:
No notification in 2 hours of waiting

Expected results:
Updates notification should appears in reasonable time (30 minutes)

Additional info:
https://fedoraproject.org/wiki/QA:Testcase_desktop_updates
Comment 2 Petr Schindler 2012-03-09 10:07:08 EST
I propose this bug as beta blocker per criterion: "The default update manager in release-blocking desktops must not periodically check for updates when the system is booted live, but must periodically check for updates when running on an installed system"
Comment 3 Adam Williamson 2012-03-09 23:02:37 EST
Discussed at 2012-03-09 blocker review meeting. Agreed this is a blocker per beta criterion "The default update manager in release-blocking desktops must not periodically check for updates when the system is booted live, but must periodically check for updates when running on an installed system" (though note that update notification can be a bit temperamental, in my experience, and it may show up after a while).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2012-03-09 23:02:51 EST
Don't suppose this is more ConsoleKit-related stuff?
Comment 5 Richard Hughes 2012-03-10 07:38:30 EST
Two hours isn't enough time. Did you get a notification after 24 hours?
Comment 6 Adam Williamson 2012-03-12 15:39:38 EDT
Richard: isn't it possible to make it reliably provide a notification faster on a fresh install? if we have to wait 24 hours to be sure whether it's working or not, that's a bit of a problem, since we're often working with pretty short timeframes for validation.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Richard Hughes 2012-03-15 12:58:44 EDT
Adam, I think this ought to do it:

gsettings set org.gnome.settings-daemon.plugins.updates last-updates-notification 42
gsettings set org.gnome.settings-daemon.plugins.updates frequency-get-updates 900

And then wait 15 minutes. Tweak the frequency-get-updates even smaller if you're impatient.
Comment 8 Adam Williamson 2012-03-15 14:03:10 EDT
Thanks! Petr, can you try that and see what happens? If we can confirm that it works we can stick it in the test case.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Petr Schindler 2012-03-19 12:21:46 EDT
It works correctly. I will update the test case. It would be nearly impossible to test this feature without this hack.
Comment 10 Adam Williamson 2012-03-19 19:43:26 EDT
Test case has been updated. Let's close this. I just checked a clean install and it defaults to a sane value (86400 = 24 hours), so we can be fairly confident it's working.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.