Bug 80179 - Adding language support?
Adding language support?
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-language (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-21 08:48 EST by Hugo van der Kooij
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 21:47:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hugo van der Kooij 2002-12-21 08:48:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Initial installation was done with support for English only.

A new user requires support for Dutch but there is no way to add it after the
installation.

Reinstalling the system is NOT an option.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install without support for Dutch
2. Try to install a Gnome application to handle Dutch

    

Actual Results:  $ gnomesword

Gdk-WARNING **: locale not supported by C library
Building GnomeSword interface
gnomesword-0.7.7
Initiating Sword

Sword locale is nl
Loading SWORD Modules

Expected Results:  Usage of the Dutch language module in the application.

Additional info:
Comment 1 Owen Taylor 2002-12-21 09:02:55 EST
All that message means is that setlocale() failed, so it's nothing to do
with GTK+.

Is the locale you specified actually 'nl'? That isn't a valid locale,
you need nl_NL.UTF-8 or nl_NL.

Did you try to install Dutch support in some manner? I'm not sure if
this is a RFE against redhat-config-packages, or a bug report about
the way the libc packages are working.


Comment 2 Hugo van der Kooij 2002-12-21 09:44:48 EST
Tried all of the suggested ones and even more so. But the error remains.

I have even tried to load additional support according to a suggestion I got
from the Psyche mailinglist.

I reinstalled glibc-common like:
rpm -Uvh glibc-common....rpm --define '_install_langs en,nl' --replacepkgs

The output of /usr/bin/locale command still does not show nl support.

So I am looking for a way to add language support without reinstalling the
system. It does not have to be an easy click and drool solution.
Comment 3 Brent Fox 2002-12-22 11:32:40 EST
Currently there is no easy way to install a language if you didn't install it
when you installed the operating system.  This is because the translations for
each package are contained in each package.  To install Dutch for example after
installation would require going through each RPM and pull out the translations
for Dutch.  

Jeremy, how do you think we should approach this?  First of all, unless we
change how translations are handled in every RPM, whatever approach we take will
require reinstalling parts of every RPM on the system.  Should
redhat-config-packages provide the GUI to do this?  Or do we need RPM changes to
make this easier?
Comment 4 Jeremy Katz 2002-12-22 12:14:38 EST
My current thinking is that we're going to switch to always installing all
translations and then you'll just have to install "language support groups" for
things such as fonts and input methods to get full support for languages.  
Comment 5 Hugo van der Kooij 2002-12-22 13:22:23 EST
Would the following procedure work?

 1. Gather all RPM files with `rpm -qa|sort`.
 2. On each package execute: `rpm -Uvh $PKG.rpm --define '-install-langs en,nl'
--replacepkgs

This was suggested on the Psyche mailinglist.

Or do I need to perform some extra steps?

I plan to write some sort of script to make it relative simple to execute.
Comment 6 Brent Fox 2002-12-23 00:54:02 EST
Jeremy, I like that idea better.  Then could we remove the "Language Support"
screen in the installer?  (please, please, please?)

Hugo, I'm not sure if that script would work or not.  Might as well give it a
try.  ;)
Comment 7 Hugo van der Kooij 2002-12-23 07:52:48 EST
I wrote down the steps I have taken on:
http://hvdkooij.xs4all.nl/linux-after8.cms#lang2

I am not convinced this is a clean solution and I do appreciate additional
information you can give based upon the current installation procedure. (I do
not understand the Python code inside anaconda at all.)
Comment 8 Brent Fox 2003-01-13 21:47:57 EST
Hugo, I'm not sure that there *is* a clean solution to the problem,
unfortunately.  There's no chance to fix it for this release.  Deferring.

Note You need to log in before you can comment on or make changes to this bug.