Bug 80181 - (Radeon IGP) RedHat v8.0 hangs at 'CD Found' screen on HP laptop while attempting to install OS
(Radeon IGP) RedHat v8.0 hangs at 'CD Found' screen on HP laptop while attemp...
Status: CLOSED DUPLICATE of bug 91889
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-21 11:12 EST by Todd
Modified: 2006-02-21 13:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HP pavilion xt118 Reference Guide - hardware specifications are on pages 136 - 138 (949.70 KB, application/pdf)
2002-12-21 11:22 EST, Todd
no flags Details

  None (edit)
Description Todd 2002-12-21 11:12:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i586)

Description of problem:
RedHat v8.0 hangs at 'CD Found' screen on HP laptop while attempting to install
OS.

Here's what was displayed on my computer as I attempted to install RedHat Linux
v8.0:

boot: ENTER
loading vmlinuz...........
....
detects hardware
...
running install...
running /sbin/loader

=================================
PC Card
Initializing PC Card devices
=================================

======================================================================
Welcome to Red Hat Linux

CD Found

To begin testing the CD media before installation press OK

Choose Skip to skip the media test and start the installation.

OK and Skip buttons

<Tab>/<Alt-Tab> between elements | <Space> selects | <F12> next screen
======================================================================

The system completely hangs at this point.  I cannot select OK, or Skip and none
of the keys at the bottom do anything, the system is completely hung.  I cannot
CTRL-ALT-FX where 1 <= X <= 6.  No keys on the keyboard work, the system is
completely hung.

I used ftp to download the iso CD-ROM images and I verified the newly burned
boot CD-ROM (using X-CDRoast on my desktop system which is running RedHat v7.2)
with the actual ISO image that was downloaded from distro.ibiblio.org and they
are byte-for-byte identical.

I tried booting using the following options and experienced the exact
same system hang problem at exactly the same point:

boot: ENTER
boot: linux text
boot: linux noprobe
boot: linux mediacheck
boot: linux nomediacheck
boot: linux rescue
boot: linux nomediacheck text noprobe skipddc

I calculated the md5sum checksum using the 
'md5sum psyche-i386-disc1.iso' command and received the following output:

todds@voyager# md5sum psyche-i386-disc1.iso
d7b16b081c20708dc0dd7d41793a4177  psyche-i386-disc1.iso

The laptop is brand new and was running Micoslop Windows XP fine before I
deleted Windows XP so that I could install RedHat v8.0.  I believe the hardware
to be in good working order.  I ran HP's nitty gritty hardware diagnostics and
all subsystems on the laptop passed the diagnostics.  I was able to install
RedHat v7.2 successfully, but the video chipset and monitor are not supported
under RedHat v7.2, therefore I cannot run X-windows or any graphical software
applications and am traveling away from home for several weeks.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Obtain a HP pavilion xt118 laptop (very similar to a HP ze4115 etc.)
2. Insert CD #1 from the RedHat v8.0 distribution
3. Boot off of the CD-ROM and attempt to install Linux RedHat v8.0
    

Actual Results:  See detailed description in the 'Description' field above

Expected Results:  RedHat Linux v8.0 should have started to walk me through the
installation procedure.

Additional info:

HP pavilion xt118 (F5861H-A101)
HP tech. support for xt118
208-323-2551
Product F5861H KE
SN CN2460 1173

Intel Celeron 1.6GHz CPU which has:
L1-trace 12K cache
L1-data   8K cache
L2      256K cache

QSI CDRW/DVD Model SBW-241
O2Micro 0Z6912 Card Bus controller
...
I'll be happy to email you a copy of the HP laptop hardware specifications if it
would be helpful.  I'm also willing to test any changes you may make on my
laptop if that would help speed up solving the problem.  Is there any way to
enable some kind of debug mode in the Linux RedHat installer so that we can
better determine exactly where the problem is occurring and what the root cause
of the problem might be?  Yep you guessed it, I'm a unemployed Unix/C software
engineer with 10 years of experience trying to get my new mobile development
system up and running.  Thanks for any information, ideas or help you may
provide.

todds@logsoft.com or toddsh@attbi.com
Comment 1 Todd 2002-12-21 11:22:25 EST
Created attachment 88842 [details]
HP pavilion xt118 Reference Guide - hardware specifications are on pages 136 - 138

HP pavilion xt118 Reference Guide - hardware specifications are on pages 136 -
138

For more information on the details of Intel Celeron 1.6GHz CPU please visit:

http://www.intel.com/home/notebook/celeron/index.htm
Comment 2 Michael Fulbright 2002-12-27 10:45:07 EST
When the system hangs, try suspending and un-suspending the laptop.
Comment 3 Todd 2002-12-29 12:37:31 EST
Forgive my naiveness, but do you have any particular way you'd like me to
suspend and resume my laptop while attempting to load Linux RedHat v8.0?
Would closing the LCD screen and re-opening it 'suspend and resume' the
laptop?  Thanks for any other ways you may know how to suspend and resume
the laptop.  I tried closing the LCD screen and re-opening it but the entire
system is still hung/frozen.  Are you able to reproduce the problem?  Any other
ideas you may have as to how to resolve it temporarily?
Comment 4 Todd 2003-01-08 01:13:58 EST
Michael Fulbright (a.k.a. msf@redhat.com)

I tried suspending and un-suspending the laptop using the same technique I use
when running Windows XP and the system remains hung when trying to install
RedHat v8.0.  Is there any kind of anaconda debug mode I can enable to further
troubleshoot this problem?  Thanks.

Comment 5 Jeremy Katz 2003-01-10 01:41:23 EST
Does it work if you boot with 'linux nopcmcia'?
Comment 6 Todd 2003-01-13 01:46:17 EST
No 'linux nopcmcia' does not work.  The system exhibits the exact same behavior
in that it hangs at the following 'CD Found' screen as described in the initial
bug report.  IS THERE ANY KIND OF SPECIAL DEBUG MODE WE CAN INVOKE AT THE boot:
PROMPT THAT WOULD BETTER HELP ISOLATE THE ROOT CAUSE OF THE PROBLEM?

======================================================================
Welcome to Red Hat Linux

CD Found

To begin testing the CD media before installation press OK

Choose Skip to skip the media test and start the installation.

OK and Skip buttons

<Tab>/<Alt-Tab> between elements | <Space> selects | <F12> next screen
======================================================================
Comment 7 NoNameExp 2003-01-13 09:29:26 EST
I got the same problem when trying to
install Red Hat Linux 8.0 on my notebook.
The keyboard cannot work when the screen
described above appears (e.g. CAPS LOCK 
does not work as well). And, the
screen shown up as described does not
seem to appear as the "Installation 
Using Graphical Mode". I believe it is
the text mode way of installation,
even I press <ENTER> only on the Options
for installing Linux. Is there any
solutions?
Comment 8 NoNameExp 2003-01-14 08:08:52 EST
I tried the installation on my PC and found that it would works,
but how come the installation just hang when I do the same thing on my
laptop computer? The keyboard just wouldn't function.
My laptop computer is the NEC Versa P440 series.
Comment 9 Michael Fulbright 2003-01-14 14:33:01 EST
I am not familiar with the HP brand of laptops - does the manual give
information on how to suspend the machine?
Comment 10 NoNameExp 2003-01-16 04:57:35 EST
Does any onc has a solution for this problem?
Does Red Hat has a fix for this problem?
Thank you.
Comment 11 NoNameExp 2003-01-16 04:59:46 EST
Note:
Red Hat Linux 7.3 was successfully installed on this machine.
But Red Hat Linux 8.0 is unable to be installed.
Comment 12 Todd 2003-01-16 19:53:07 EST
I found this information in the HP laptop manual which I also included in PDF
format with this bug report:

PC Card (PCMCIA) Problems 
If the notebook doesn t recognize a PC Card: 
Remove and reinsert the PC Card.
Press the power button to suspend the computer, and then press it again to resume.

When I boot up using the RedHat v8.0 CD and the system hangs as reported, and
press the power button to 'suspend' the computer, and then press the power
button again to resume, it actually power cycles the computer and does not
suspend the computer as you would think.  My guess is that since no OS is
actually loaded yet, the special RedHat software that 'catches' the suspend
event can not prevent the laptop from actually power cycling.  Just curious, is
there a RedHat module that will automatically suspend/sleep the laptop after say
15 minutes of activity?  My experience with Microslop operating systems is that
this suspend/sleep feature is controlled in software by the OS.
Comment 13 Todd 2003-01-16 20:01:42 EST
Here's some more information that I found from the HP reference manual:

If the computer doesn t suspend to Standby mode as expected · If you have a
connection to another computer, the computer won t suspend if the connection is
active.

If the computer is performing an operation, it normally waits for the operation
to finish before suspending. 

If the computer doesn't automatically hibernate as expected · Make sure
hibernate support is enabled. From Control Panel, open Power Options, and then
click the Hibernate tab. Also, check the Power Schemes tab. Make sure the
Hibernate timeouts for both AC power and battery power are not set to Never.

If the computer takes a long time to resume after being suspended · The computer
can routinely take a minute or more to resume if it has a network card
installed. While the operating system is loading drivers and checking hardware
and network connections, you will see a blinking cursor on your display. As soon
as the hardware has been re-initialized, the Windows desktop will appear.

Power Rechargeable lithium-ion (14.8 Vdc) battery with LED charge-level gauge.
Fast battery recharge: 2 hours when system is off, 3 hours when system is on.
Low-battery warning. Suspend/resume capability. Universal AC adapter: 100 240
Vac (50/60 Hz) input, 19 Vdc output, 75 W.
Comment 14 NoNameExp 2003-01-20 20:35:34 EST
...
So far, I haven't saw Linux has such many power options...
Suspend, Hibernate are all Windows features (?).
A computer definitely would not suspend when no OS is loaded.
Anyway, I don't think suspending the computer would help
to solve the problem.
But anyway, how to solve this problem, or 'bug'?
I encountered the same problem, too.
May somebody help or does Red Hat has a fix of this?
It is somewhat strange to have anaconda for version 7.3 
being able to work correctly but not working correctly
for version 8.0, which is the later version and
which shall be better.
Comment 15 Todd 2003-01-21 12:18:52 EST
Is there any kind of undocumented debug mode I can invoke at say the boot:
prompt that would assist us to determine the actual cause of the problem or at
least determine what module the problem is occurring in?
Comment 16 Michael Fulbright 2003-01-30 15:13:19 EST
The only debugging information availabe is on VC3 (hit cntl-alt-f3), and kernel
output messages are on VC4 (cntl-alt-f4).

If you system is hung you may not be able to switch to these consoles. In that
case switch to one of them just before the phase where the machine hangs.
Comment 17 Todd 2003-01-31 15:36:29 EST
Thanks for the information on obtaining some kind of debug information to help
further isolate this problem.  I rebooted the computer four or five times before
I was able to get the following debug information as I wasn't able to get the
CTRL-ALT-F3 and/or CTRL-ALT-F4 screens to come up.  The really strange thing is
that when I finally got the CTRL-ALT-F3 and/or  screens to show up, I was able
to jump back and forth between the two screens even though the CTRL-ALT-F1 would
not let me TAB between the CD Found OK and Skip options.  I wrote down all of
the debug information (shown below), and when I went back to CTRL-ALT-F1 screen,
the computer was not hung anymore on the CD Found screen.  Because the screen
wasn't hung anymore, I was even able to run the media test and the CD-ROM passed
the media test.  

For your information, the CD Rom drive is a QSI CDRW/DVD SBW-241.

Lines that stick out in the debug information to me are:

Interesting debug information on screen CTRL-ALT-F3
===================================================
* module(s) usb-ohci not found
...
* trying to mount device hdc
* mntloop loop0 on /mnt/runtime as /mnt/source/RedHat/base/stage2.img fd is 10
* MD5SUM -> 3218284f8826bf95ccd6f248ad9229f0
* skipsectors = 15
* isostatus = 0

Interesting debug information on screen CTRL-ALT-F4
===================================================
<27>Jan 31 14:51:43 cardmgr[47]: config error, file 'config' line 1053: syntax
error
<27>Jan 31 14:51:43 cardmgr[47]: config error, file 'config' line 2129 no
function bindings
<30>Jan 31 14:51:43 cardmgr[47]: watching 1 sockets
<30>Jan 31 14:51:43 cardmgr[47]: Card Services release does not match
...
<30>Jan 31 14:51:43 cardmgr[47]: could not open /var/run/cardmgr.pid
<30>Jan 31 14:51:43 cardmgr[47]: fopen(stabfile) failed:
...
<4>Unable to identify CD-ROM format.
<4>VFS: Can't find ext2 filesystem on dev loop(7,0)


All debug information on screen CTRL-ALT-F3
===========================================
* inserted /tmp/pcmcia_core.o
* load module set done
* modules to insert yenta_socket ds
* inserted /tmp/yenta_socket.o
* inserted /tmp/ds.o
* load module set done
* cardmgr running as pid 47
* cardmgr returned 0x0
* probing buses
* finished bus probing
* modules to insert natsemi usb-ohci
* module(s) usb-ohci not found
* inserted /tmp/natsemi.o
* load module set done
* probing buses
* finished bus probing
* modules to insert usb-ohci
* module(s) usb-ohci not found
* load module set done
* trying to mount device hdc
* mntloop loop0 on /mnt/runtime as /mnt/source/RedHat/base/stage2.img fd is 10
* MD5SUM -> 3218284f8826bf95ccd6f248ad9229f0
* skipsectors = 15
* isostatus = 0

All debug information on screen CTRL-ALT-F4
===========================================
<30>Jan 31 14:51:43 cardmgr[47]: starting, version is 3.1.31
<27>Jan 31 14:51:43 cardmgr[47]: config error, file 'config' line 1053: syntax
error
<27>Jan 31 14:51:43 cardmgr[47]: config error, file 'config' line 2129 no
function bindings
<30>Jan 31 14:51:43 cardmgr[47]: watching 1 sockets
<30>Jan 31 14:51:43 cardmgr[47]: Card Services release does not match
<6>cs: IO port probe 0x0c00-0x0cff: clean.
<6>cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x408-0x40f
0x480-0x48f 0x4d0-0x4d7
<6>cs: IO port probe 0x0a00-0x0aff: clean
<30>Jan 31 14:51:43 cardmgr[47]: could not open /var/run/cardmgr.pid
<30>Jan 31 14:51:43 cardmgr[47]: fopen(stabfile) failed:
<30>Jan 31 14:51:43 cardmgr[47]: exiting
<6>natsemi.c:v1.07 1/9/2001 Written by Donald Becker <becker@scyld.com>
<6>  http://www.scyld.com/network/natsemi.html
<6>  (unofficial 2.4.x kernel port, version 1.07+LK1.0.14, Nov 27, 2001  Jeff
Garzik, Tjeerd Mulder)
<6>PCI: Found IRQ 10 for device 00:12.0
<7>divert: allocating divert_blk for eth1
<6>eth1: NatSemi DP8381[56] at 0xce884000, 00:c0:9f:1a:36:82, IRQ 10.
<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to identify CD-ROM format.
<4>VFS: Can't find ext2 filesystem on dev loop(7,0)

I hope this information helps further isolate this problem.  I would appreciate
it if you could please take a look at this information as soon as possible.
Comment 18 Michael Fulbright 2003-02-03 14:12:41 EST
Unfortunately everything looks fine.

This is most probably a kernel issue with this particular laptop.

If you purchased the product from Red Hat you can talk to customer support about
a refund.
Comment 19 Matt Evett 2003-02-07 11:48:45 EST
Two of my students have run into the same problem trying to install v8.0 on
their laptops: a compaq presario 2100, and a toshiba.  So it looks like this
problem is not peculiar to any one manufacturer, but probably to a shared piece
of hardware.  The ctl-alt-f3 and ctl-alt-f4 trick does the trick.  After getting
those debugging screens displayed, ctl-alt-f1 gets you back into anaconda, but
now the installation process is no longer hung.
Comment 20 Charles Finkel 2003-05-15 01:26:34 EDT
I am having the same problem as well, only this happens with Red Hat 9 as well
as Red Hat 8.0.  I too had Red hat 7.3 installed on the same machine without a
problem, and I used the same CDs to install Red Hat 9 on a different machine. 
The machine I am running on is a Dell Dimension 8250.

I've tried the Ctrl-Alt-F3 and Ctrl-Alt-F4 trick about ten times, with no luck
in getting the debug screen to come up.  When exactly am I meant to press them?
 Just an instant before the 'CD Found' screen appears?  And should I continually
press them, or just press them once at the right time?  For those that did get
this trick to work - can you give more details on how you did it?
Comment 21 Alan Cox 2003-06-08 15:43:01 EDT
Eventually this was figured out. There are some incompatibilities between older
Red Hat and the Radeon IGP chipset.  With Red Hat 9 images and ide=nodma such a
system is reported ot install correctly.  We hope to have it fully handled in
the next release.
Comment 22 Alan Cox 2003-06-09 10:08:00 EDT

*** This bug has been marked as a duplicate of 91889 ***
Comment 23 Red Hat Bugzilla 2006-02-21 13:50:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.