This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 801821 - Ensure that starter web application is always started last
Ensure that starter web application is always started last
Status: CLOSED CANTFIX
Product: JBoss Enterprise Portal Platform 5
Classification: JBoss
Component: Portal (Show other bugs)
5.2.0.GA
Unspecified Unspecified
low Severity low
: ---
: 5.2.2.CR01
Assigned To: hfnukal@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 10:19 EST by bkramer
Modified: 2012-08-27 20:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If portal extension project is named with lowercase letter, it is possible that it starts later then necessary services, and throws java.lang.IllegalStateException. To workaround this issue, always use an uppercase first letter. This current functionality will be improved in a future release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 10:00:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2012-03-09 10:19:19 EST
Description of problem:

I've recently tried to name a portal extension project which started with the lowercase letter 'u' and it failed to deploy the extension with the following exception:

java.lang.IllegalStateException: No pre init tasks can be added to the portal container 'portal', because it has already been initialized. 

It turns out that reason failure was because the 'starter' webapp had already been initialized prior to the deployment of the portal extension.

By renaming the project to start with an 'a' or 'U' the problem disappears and in the logs we can see that indeed the extension is deployed prior to the 'starter' webapp.

We should ensure that starter webapp is always started last.


Version-Release number of selected component (if applicable):
EPP 5.2

How reproducible:
always

Steps to Reproduce:
1. rename docs/examples/portal/gatein-sample-extension.ear into for instance ugatein-sample-extension.ear;
2. deploy ugatein-sample-extension.ear, together with gatein-sample-portal-ds.xml and make sure that gatein-ds.xml is changed by adding '_portal' to the jndi names.
3. start the server
  
Actual results:
The following exception is logged: java.lang.IllegalStateException: No pre init tasks can be added to the portal container 'portal', because it has already been initialized. 

Expected results:
No exception is logged and application is properly deployed.

Additional info:
Comment 1 hfnukal@redhat.com 2012-06-28 10:44:20 EDT
Need to mention in doc.
Comment 2 Jared MORGAN 2012-08-20 20:41:42 EDT
This issue was closed as CANTFIX. 

What do I need to mention? This should get its own docs bug if a change to documentation is required. 

What do you want to say in the release notes? Is this a work around?
Comment 3 Jared MORGAN 2012-08-20 20:41:42 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
NEEDINFO: What needs to be mentioned in the doc specifically?

CAUSE:

CONSEQUENCE:

FIX:

RESULT:
Comment 4 hfnukal@redhat.com 2012-08-24 07:01:56 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,9 +1,9 @@
 NEEDINFO: What needs to be mentioned in the doc specifically?
 
-CAUSE:
+CAUSE: If portal extension project is named with lowercase letter
 
-CONSEQUENCE:
+CONSEQUENCE: it is poossible that it starts later then necessary services, and throws java.lang.IllegalStateException
 
-FIX:
+FIX: Use uppercase first letter.
 
-RESULT:+RESULT: We should ensure that starter webapp is always started last.
Comment 5 hfnukal@redhat.com 2012-08-24 07:02:13 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,5 +1,3 @@
-NEEDINFO: What needs to be mentioned in the doc specifically?
-
 CAUSE: If portal extension project is named with lowercase letter
 
 CONSEQUENCE: it is poossible that it starts later then necessary services, and throws java.lang.IllegalStateException
Comment 6 Jared MORGAN 2012-08-27 20:32:55 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1 @@
-CAUSE: If portal extension project is named with lowercase letter
+If portal extension project is named with lowercase letter, it is possible that it starts later then necessary services, and throws java.lang.IllegalStateException. To workaround this issue, always use an uppercase first letter. This current functionality will be improved in a future release.-
-CONSEQUENCE: it is poossible that it starts later then necessary services, and throws java.lang.IllegalStateException
-
-FIX: Use uppercase first letter.
-
-RESULT: We should ensure that starter webapp is always started last.

Note You need to log in before you can comment on or make changes to this bug.