Bug 801862 - Users reporting errors on rhc-create-app: "Invalid Profile: large. Must be: std or small"
Users reporting errors on rhc-create-app: "Invalid Profile: large. Must be: s...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Mike McGrath
libra bugs
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 11:56 EST by Nam Duong
Modified: 2015-05-14 21:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 14:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-03-09 11:56:54 EST
Description of problem:
Users are reporting errors on rhc-create-app:
https://www.redhat.com/openshift/community/forums/express/since-yesterday-a-jboss-error-drive-my-crazy#comment-15895
---------
rhc-create-app --type jbossas-7 -d --app=jblog --rhlogin=myuser@gmail.com --password=mypass

and the error output

Submitting form:
rhlogin: myuser@gmail.com
debug: true
Contacting https://openshift.redhat.com
Creating application: jblog
Contacting https://openshift.redhat.com
Problem reported from server. Response code was 400.

DEBUG:

Exit Code: 1
api_c: ["placeholder"]
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"]
API version: 1.1.2

RESULT:
Invalid Profile: large. Must be: std or small
---------


I was able to reproduce this with 0.85.12 prior to updating, but the user whom reported this seems to be on the release just prior to our recent update.

"Importantly, when this happens, the error message isn't helpful. It doesn't say, "you have an older version of the client tools - please upgrade with [gem install rhc-foo-blah]" it just gives a random error." discussion notes 3/8
Comment 1 Mike McGrath 2012-03-12 15:01:21 EDT
Very very strange.  This almost makes me feel like we had a buggy client tools in a previous release.  The default should always have been empty.  Either way this bug does not exist in the current client tools.
Comment 2 Mike McGrath 2012-03-12 15:04:04 EDT
Actually pushing this through the normal QA process.
Comment 3 Linqing Lu 2012-03-13 02:17:39 EDT
verified with rhc-0.87.8-1.el6_2.noarch on devenv1659, there is some NOTICE info for users about updating their clients

[lilu@localhost ~]$ rhc-create-app --type jbossas-7 -d --app=jblog
Password: 
Submitting form:
debug: true
rhlogin: lilu+1@redhat.com
Contacting https://ec2-174-129-173-36.compute-1.amazonaws.com
Creating application: jblog
Contacting https://ec2-174-129-173-36.compute-1.amazonaws.com
Problem reported from server. Response code was 400.

DEBUG:


Exit Code: 1
api_c: placeholder
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
API version:    1.1.3

RESULT:
Invalid Profile: std.  Must be: (jumbo|exlarge|large|micro|std)


NOTICE: Client API version (1.1.2) does not match the server (1.1.3).
Though requests may succeed, you should consider updating your client tools.

Note You need to log in before you can comment on or make changes to this bug.