Bug 801894 - 'Red Hat Cluster Suite' name is incorrect
'Red Hat Cluster Suite' name is incorrect
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-firewall (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Thomas Woerner
qe-baseos-daemons
: EasyFix
Depends On:
Blocks: 947782
  Show dependency treegraph
 
Reported: 2012-03-09 13:54 EST by Lon Hohberger
Modified: 2014-04-03 08:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-03 08:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2012-03-09 13:54:28 EST
Description of problem:

* Cluster Suite was a RHEL add-on in the RHEL3/4 products; it is called the 'High Availability Add-On' in RHEL5.5+/6+

* The port assignments look correct, although the documentation states that 
  16851/TCP should also be opened.

Version-Release number of selected component (if applicable): system-config-firewall-1.2.27-5.el

Actual results:
  '[ ] Red Hat Cluster Suite'

Expected results:
  '[ ] Red Hat High Availability'
Comment 2 RHEL Product and Program Management 2012-09-07 00:58:46 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Lon Hohberger 2013-04-25 10:13:06 EDT
I think you can close this.  IIRC, the name is also represented in the CLI tools, and breaking CLI is not worth it.
Comment 4 Thomas Woerner 2013-04-25 10:21:30 EDT
All parts of system-config-firewall are using this for cli and gui:

    _Service("cluster-suite", _("Red Hat Cluster Suite"), [
            # corosync/openais
            (5404, "udp"), (5405, "udp"),
            # ricci
            (11111, "tcp"),
            # dlm
            (21064, "tcp"),
            ],
             _("This option allows you to use the Red Hat Cluster Suite. "
               "Ports are opened for openais, ricci and dlm. You need the "
               "Red Hat Cluster Suite installed for this option to be "
               "useful.")),

If we change it, it will get changed everywhere in system-config-firewall.

I have just seen that also the tag of the entry is "cluster-suite". If we change this, then the use of the old name will result in an error. Is it documented (by us or externally) to use "cluster-suite"?
Comment 5 Lon Hohberger 2013-04-25 10:36:07 EDT
This is what we document (which perhaps isn't ideal; not sure):

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html-single/Cluster_Administration/index.html#s2-iptables_firewall-CA

However, I think that there's risk that someone is using kickstart (or whatever) and system-config-firewall (lokkit, really) in deployment scripts.  That's what I didn't consider when I filed this bug.

e.g.
  # lokkit -s cluster-suite

I'd be worried that changing this would break someone's deployment scripts.
Comment 9 Thomas Woerner 2014-04-03 08:21:47 EDT
Closing as NOT A BUG due to comment #5.

Note You need to log in before you can comment on or make changes to this bug.