Bug 801911 - Able to delete Cloud with running instances - orphaned instance and zones
Able to delete Cloud with running instances - orphaned instance and zones
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: beta6
: ---
Assigned To: Tzu-Mainn Chen
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 15:03 EST by Steve Reichard
Modified: 2012-05-15 18:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: v0.8.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
movie (6.58 MB, video/ogg)
2012-03-09 15:03 EST, Steve Reichard
no flags Details
image_detail (207.88 KB, image/png)
2012-04-04 01:59 EDT, Rehana
no flags Details
auto_image_detail (211.84 KB, image/png)
2012-04-04 01:59 EDT, Rehana
no flags Details

  None (edit)
Description Steve Reichard 2012-03-09 15:03:28 EST
Created attachment 568991 [details]
movie

Description of problem:

I was able to delete a cloud that has a zone with a running instance.  While a pop up prompted that "Are you sure you want to delete?", it did not inform me that I 'd have orphaned instances and images.  Also my Blueprints and catalog would disappear.

I now have zone that shows up in the Monitor tab but do not show up in the Administer | Cloud  or Content | Catalogs pages. 




Version-Release number of selected component (if applicable):


[root@cf-cloudforms5 imagefactory]# /pub/scripts/post_install_configuration_scripts/cf-versions 
Red Hat Enterprise Linux Server release 6.2 (Santiago)
Linux cf-cloudforms5.cloud.lab.eng.bos.redhat.com 2.6.32-220.4.2.el6.x86_64 #1 SMP Mon Feb 6 16:39:28 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
postgresql-8.4.9-1.el6_1.1.x86_64
mongodb-1.8.2-3.el6.x86_64
euca2ools-1.3.1-4.el6_0.noarch
ruby-1.8.7.352-6.el6.x86_64
rubygems-1.8.16-1.el6.noarch
deltacloud-core-0.5.0-5.el6.noarch
rubygem-deltacloud-client-0.5.0-2.el6.noarch
package libdeltacloud is not installed
hail-0.8-0.2.gf9c5b967.el6_0.x86_64
puppet-2.6.11-1.el6_1.noarch
aeolus-configure-2.5.0-16.el6.noarch
iwhd-1.2-3.el6.x86_64
imagefactory-1.0.0rc8-1.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch
aeolus-conductor-0.8.0-39.el6.noarch
[root@cf-cloudforms5 imagefactory]# 



How reproducible:


I've captured a movie of my attempt to re-create.  The cloud is call del-cloud, witha zone called, delzone.  

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tzu-Mainn Chen 2012-03-14 10:56:27 EDT
Patch created:

https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009568.html
Comment 2 Tzu-Mainn Chen 2012-03-16 11:53:58 EDT
Pushed these three to master:

commit 09db566ffb846464715f693f595ee4cbf80c9f25
BZ 801911 added checks before destroying a pool family

commit ad149a629edcf85309f5eab2d6b8785eda451381
BZ 801911 check that pools are destroyable before destroying a pool family

commit 3c817efa5db688b6913e547588434792f5f8a9dd
BZ 801911 added/clarified text related to pool family deletion

And pushed this to 1.0-product:

commit 7facfc3969ce612b1bd67e4a4e4301f8e579e3ec
BZ 801911 added/updated overrides dealing with cloud deletion
Comment 4 wes hayutin 2012-03-30 14:57:50 EDT
assigning to rehana
Comment 5 Rehana 2012-04-04 01:58:37 EDT
Observed that deletion of cloud with running instance is now not allowed, it displays appropriate error message "Cloud cannot be deleted! Check to make sure all instances are stopped" and also the confirmation message before delete operation informs user clearly with this message "Are you sure you want to delete this cloud? All related cloud resource zones, catalogs, and application blueprints will be deleted too!"

also attached "catalog" and "CRZ" to this cloud got deleted when the "cloud" was deleted..However Observed that the image entry is stilll there but the ami id and uuid got deleted. keeping this information is of NO USE as user cant do any operation (rebuild/push)on this image. (PFA: image detail.png)

Also i observed this bug https://bugzilla.redhat.com/show_bug.cgi?id=798725. (appears the image details as a result of auto refresh) (PFA:Auto_image_detail.png)


observed this on;

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch

hence setting status back to "Assigned"
Comment 6 Rehana 2012-04-04 01:59:12 EDT
Created attachment 575036 [details]
image_detail
Comment 7 Rehana 2012-04-04 01:59:54 EDT
Created attachment 575037 [details]
auto_image_detail
Comment 8 Rehana 2012-04-04 09:39:29 EDT
Moving the bug status to Verified, appropriate error msg displayed while deleting the CRZ which has instance in running state

PFA:ss1.png 

observed this on;

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 9 errata-xmlrpc 2012-05-15 18:51:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.