Bug 801922 - liblfc.so can be used as a runtime module
liblfc.so can be used as a runtime module
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: lcgdm (Show other bugs)
el5
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Mattias Ellert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 15:52 EST by Brian Bockelman
Modified: 2012-03-10 14:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-10 14:44:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Bockelman 2012-03-09 15:52:51 EST
Description of problem:

liblfc.so is used by some software (particularly lcg-utils in EMI and OSG, though that's not in EPEL/Fedora, so I don't know if that counts) as a runtime loadable module.

Because of this, I believe the "/usr/lib/liblfc.so" symlink should be included in the lfc-libs package, not lfc-devel.

Can this change be made?  Or is this the correct approach?

Thanks in advance,

Brian

Version-Release number of selected component (if applicable):

1.8.x

How reproducible:

N/A
Comment 1 Mattias Ellert 2012-03-10 14:44:34 EST
Neither including the .so symlink in the library package, nor adding a runtime dependency on the devel package is the rigth thing to do in this case.

The proper thing to do when packaging for Fedora and EPEL is to patch the package dlopening the library to dlopen the versioned library, i.e. liblfc.so.1 in this case.

See for example the discussion in the Package Review in bug #592670 comment #17.

Note You need to log in before you can comment on or make changes to this bug.