Bug 801925 - Build failure
Build failure
Status: CLOSED DUPLICATE of bug 790528
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: imagefactory (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: jrd
Martin Kočí
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 15:57 EST by Steve Reichard
Modified: 2013-02-26 23:26 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 07:42:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Reichard 2012-03-09 15:57:54 EST
Description of problem:


this is related to BZ 801907

When I attempt  a build all, at least one of the builds failed.  Others succeeded.

I saw this trace in imagefactory.log:

2012-03-09 14:04:27,972 DEBUG imgfac.builders.BaseBuilder.RHEL6_rhevm_Builder
thread(2b438956) Message: Exception caught in ImageFactory
2012-03-09 14:04:27,994 DEBUG imgfac.builders.BaseBuilder.RHEL6_rhevm_Builder
thread(2b438956) Message: Traceback (most recent call last):
  File
"/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_rhevm_Builder.py",
line 66, in build_image
    self.build_upload(build_id)
  File
"/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_rhevm_Builder.py",
line 117, in build_upload
    self.output_descriptor = guest.customize_and_generate_icicle(libvirt_xml)
  File "/usr/lib/python2.6/site-packages/oz/RedHat.py", line 1178, in
customize_and_generate_icicle
    return self._internal_customize(libvirt_xml, True)
  File "/usr/lib/python2.6/site-packages/oz/RedHat.py", line 1162, in
_internal_customize
    self.build_upload(build_id)
  File
"/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_rhevm_Builder.py",
line 117, in build_upload
    self.output_descriptor = guest.customize_and_generate_icicle(libvirt_xml)
  File "/usr/lib/python2.6/site-packages/oz/RedHat.py", line 1178, in
customize_and_generate_icicle
    return self._internal_customize(libvirt_xml, True)
  File "/usr/lib/python2.6/site-packages/oz/RedHat.py", line 1162, in
_internal_customize
    self._collect_teardown(modified_xml)
  File "/usr/lib/python2.6/site-packages/oz/RedHat.py", line 274, in
_collect_teardown
    g_handle = self._guestfs_handle_setup(libvirt_xml)
  File "/usr/lib/python2.6/site-packages/oz/Guest.py", line 886, in
_guestfs_handle_setup
    g.launch()
  File "/usr/lib/python2.6/site-packages/guestfs.py", line 152, in launch
    return libguestfsmod.launch (self._o)
RuntimeError: link: /tmp/.guestfs-0/kernel /tmp/.guestfs-0/kernel.13749: File
exists


I've attached a log tar ball.


Version-Release number of selected component (if applicable):



 beta 3

[root@cf-cloudforms5 log]# /pub/scripts/post_install_configuration_scripts/cf-versions 
Red Hat Enterprise Linux Server release 6.2 (Santiago)
Linux cf-cloudforms5.cloud.lab.eng.bos.redhat.com 2.6.32-220.4.2.el6.x86_64 #1 SMP Mon Feb 6 16:39:28 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
postgresql-8.4.9-1.el6_1.1.x86_64
mongodb-1.8.2-3.el6.x86_64
euca2ools-1.3.1-4.el6_0.noarch
ruby-1.8.7.352-6.el6.x86_64
rubygems-1.8.16-1.el6.noarch
deltacloud-core-0.5.0-5.el6.noarch
rubygem-deltacloud-client-0.5.0-2.el6.noarch
package libdeltacloud is not installed
hail-0.8-0.2.gf9c5b967.el6_0.x86_64
puppet-2.6.11-1.el6_1.noarch
aeolus-configure-2.5.0-16.el6.noarch
iwhd-1.2-3.el6.x86_64
imagefactory-1.0.0rc8-1.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch
aeolus-conductor-0.8.0-39.el6.noarch
[root@cf-cloudforms5 log]# 



How reproducible:

unknown at this time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Brad P. Crochet 2012-03-12 07:42:20 EDT

*** This bug has been marked as a duplicate of bug 790528 ***

Note You need to log in before you can comment on or make changes to this bug.