Bug 80194 - redhat-config-network-cmd --profile does nothing
redhat-config-network-cmd --profile does nothing
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On: 82453
Blocks: 81720
  Show dependency treegraph
 
Reported: 2002-12-21 20:28 EST by jerry asher
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 10:08:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzipped tar of /etc/sysconfig/networking and sysconfig/network-scripts (30.07 KB, application/octet-stream)
2002-12-21 21:24 EST, jerry asher
no flags Details

  None (edit)
Description jerry asher 2002-12-21 20:28:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

Description of problem:
I have a laptop with builtin ethernet and a wifi card.  On my home LAN, I want
to use static ip addresses.  When away from the home office, I want to use dhcp.

I have created a variety of profiles and seemingly each one accurately describes
the network configuration.  But neither the gui redhat-config-network or using
redhat-config-network-cmd --profile will bring the interfaces down and then
bring them up with the new profile's configuration.

Once more:

redhat-config-network-cmd --profile WILL copy/modify all sorts of files in
/etc/sysconfig/networking, but it will not actually bring the interfaces down
and then bring them up.

Should it?  If not, what is the smooth way of changing profiles?  If it is
useful, I can send you any amount of zipped up /etc/ files you wish.

Also, it's not at all clear from the documentation (customization guide) how I
create a profile in which a default device has been deactivated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
0. ifconfig
1. make a profile
2. make that profile different in some way (dhcp for instance) from the default
profile
3. redhat-config-network --profile <that-profile>

    

Actual Results:  your interface configurations as seen by ifconfig remains the
same as in step 0.

Expected Results:  ifconfig should have shown your interfaces using the config
specified by the profile you selected.

Additional info:
Comment 1 jerry asher 2002-12-21 21:24:08 EST
Created attachment 88850 [details]
gzipped tar of /etc/sysconfig/networking and sysconfig/network-scripts

These are the networking scripts and profiles I am using.  The files under
profiles/ have been tweaked by hand, as I could not get the
redhat-config-network to create them as I think they were intended to be
created.  Mainly, I deleted ifcfg-eth0 and ifcfg-eth1 from the non-default
profiles since when these files existed they completely overrode the
ifcfg-eth0PROFILE settings.
Comment 2 jerry asher 2002-12-21 22:28:11 EST
My actual configuration is as follows:
Dell Inspiron 8200, running RH 8.0.  Builtin ethernet.  Dell TrueMobile
(orinoco) WiFi card.

On my home LAN I am NOT running DHCP.  On my home LAN I sometimes
connect in my office using the ethernet, and sometimes in the kids
room using WiFi.  As the laptop provides various services to other
machines, I would like:

a) when wired to have the eth0 IP be 192.168.0.64
b) when wireless to have the eth1 IP be 192.168.0.64

When away from home, I am happy with both interfaces using DHCP.

So I created four profiles:
1) Common/default
2) HomeWired
     eth0 IP 192.168.0.64
     eth1 IP 192.168.0.65
3) HomeWireless
     eth0 IP 192.168.0.65
     eth1 IP 192.168.0.64
4) DHCP
     eth0 DHCP
     eth1 DHCP


For both eth0 and eth1 I copied these into three (each) additional
network devices:

eth0HomeWired, eth0HomeWireless, eth0HomeDHCP
eth1HomeWired, eth1HomeWireless, eth1HomeDHCP

And I set their parameters according to the table above.

Which of these should be activated in the common profile?

When I assign eth0 and eth1 to the common profile using the
network-config-tool, then it creates ifcfg-eth0 and ifcfg-eth1 scripts
in EVERY networking/profiles/ directory.  The existence of these files
mean that when I select that profile using the gui or using
redhat-config-network-cmd -profile that the common ifcfg-eth files are
used and not the profile specific files.


So how should I set the common/default profile?  And the other profiles?

In other profiles, how do I indicate which interfaces are activated
(ifup?) and which should be deactivated (ifdown)?

How do I easily switch between profiles?


Comment 3 Harald Hoyer 2003-01-09 09:10:31 EST
how about:
# service network stop
# redhat-config-network --profile <that-profile>
# service network start
??
Comment 4 jerry asher 2003-01-13 14:26:29 EST
Hi Harald,

Thanks for your response.  Though it doesn't address my question about how
different profiles interact with each other, at least it tells me how I am to use

redhat-config-network

Truly, I find redhat-config-network to be very confusing in what it does or how
I am supposed to use it, esp. as it relates to what and how profiles are to be
used.  I bet I am not the only user to do so.  More fleshed out documentation
would be so useful!

I would be happy to speak with you further about this -- one of Apple's and
Microsoft's features these days are that both systems make changing network
profiles easy and useful.  I find Microsoft's "timeout to the alternate
configuration" very useful -- I specify DHCP as the primary config, and then use
my home lan static ip addrs as the alternate config and that works 95% of the
time.  I find Apple's support of many different profiles all selectable from one
command menu entry to be a very easy interface.

Thanks again,

Jerry
Comment 5 Miloslav Trmac 2003-01-14 02:53:11 EST
You can also pass profile name at boot using netprofile=PROFILE,
so you can use the GRUB menu to select a profile.
Comment 6 derrien 2003-01-22 05:42:57 EST
netprofile=PROFILE doesn't work because there is a bug in the script
/etc/rc.d/rc.sysinit :

# Boot time profiles. Yes, this should be somewhere else.
if grep -q "netprofile=" /proc/cmdline ; then
    cmdline=`cat /proc/cmdline`
    for arg in cmdline ; do                           
       if [ "${arg##netprofile=}" != "${arg}" ]; then
          [ -x /usr/sbin/redhat-config-network-cmd ] &&
            /usr/sbin/redhat-config-network-cmd --profile ${arg##netprofile=}
       fi
    done
fi

==> the line for arg in cmdline ; do
should be for arg in $cmdline ; do

And like Jerry I find very confusing the way it's works... when I modify a
device in a profile it is also modified in the others profiles; why ?
Comment 7 jerry asher 2003-01-22 07:16:31 EST
Yes, derrien has it right -- modify a device in one profile and it gets modified
in the other profiles too.  I just have no idea of how the different profiles
interact with one another.  

Um, have you guys tried watching intelligent people that aren't the developers
try this UI out?  Because we're not stupid, but I sure don't understand how it's
supposed to work.
Comment 9 Harald Hoyer 2003-03-31 08:59:02 EST
in the profiles, it is only stored if a device should be used, or not. So if you
checkmark on the left, you specify the device to be used in the profile.
If you want to have different setups for one device. Make a copy of the device,
create two profiles and select only one device-config in either profile.
Comment 11 Harald Hoyer 2003-08-11 10:08:12 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html

Note You need to log in before you can comment on or make changes to this bug.