Bug 802009 - Touchpad stopped working after update
Touchpad stopped working after update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 03:38 EST by Will Kemp
Modified: 2012-04-19 19:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 19:49:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Kemp 2012-03-10 03:38:18 EST
Description of problem:I installed F16 from the live USB stick image and the touchpad worked ok. Then i did a yum update and after that the touchpad stopped working completely. I've marked this as an xorg problem, but i'm not certain that's what it really is. Xorg was updated to xorg-x11-server-Xorg-1.11.4-1.fc16.i686 however the kernel was updated to  kernel-3.2.9-1.fc16.i686 at the same time.

Version-Release number of selected component (if applicable): kernel-3.2.9-1.fc16.i686

How reproducible: unknown

Steps to Reproduce:
1. install from F16 live USB
2. run yum update
3.
  
Actual results:
Touchpad doesn't work

Expected results:
Touchpad does work

Additional info: Synaptics touchpad in a Acer Aspire One D270 netbook.

From dmesg:
[    4.248370] psmouse serio2: synaptics: Touchpad model: 1, fw: 7.2, id: 0x1c0b1, caps: 0xd04733/0xa40000/0xa0000
[    4.291735] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio2/input/input5


From Xorg.0.log:
[    85.738] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/
dev/input/event5)
[    85.739] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpa
d catchall"
[    85.739] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catc
hall"
[    85.739] (II) LoadModule: "synaptics"
[    85.740] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    85.740] (II) Module synaptics: vendor="X.Org Foundation"
[    85.740]    compiled for 1.11.1, module version = 1.5.0
[    85.740]    Module class: X.Org XInput Driver
[    85.740]    ABI class: X.Org XInput driver, version 13.0
[    85.740] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    85.740] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    85.740] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    85.740] (**) Option "Device" "/dev/input/event5"
[    85.772] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5612
[    85.772] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4618
[    85.772] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    85.772] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 
0
[    85.773] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    85.773] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    85.774] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    85.774] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    85.774] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio2/input/input5/event5"
[    85.775] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 11)
[    85.775] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    85.775] (**) synaptics: SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[    85.775] (**) synaptics: SynPS/2 Synaptics TouchPad: AccelFactor is now 0.038
[    85.776] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    85.777] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    85.777] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    85.777] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    85.777] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    85.779] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    85.779] (II) No input driver specified, ignoring this device.
[    85.780] (II) This device may have been added with another device file.
Comment 1 Patrick 2012-03-13 08:07:51 EDT
(In reply to comment #0)

I have a similar laptop from Acer. Are you sure you didn't disable the touchpad by accidentally pressing the disable-touchpad-key (Fn+F7)? I ask this because I did that and it cost me 2 hours to realize :-)
Comment 2 Will Kemp 2012-03-14 03:39:57 EDT
No, it's not that. That was the first thing i checked!
Comment 3 Peter Hutterer 2012-03-26 06:50:38 EDT
gsettings get org.gnome.settings-daemon.peripherals.touchpad  touchpad-enabled

returns true?
Comment 4 Will Kemp 2012-04-04 18:15:55 EDT
Yes, it returns true.
Comment 5 Will Kemp 2012-04-04 18:20:40 EDT
However, that's a bit academic now, as the last two kernel updates (3.2.9-1.fc16.i686 and 3.2.10-3.fc16.i686) have brought a new problem - when X starts the system reboots. With the 3.1.0-7 kernel X starts up ok. But i guess that's a different bug and i should report it separately...
Comment 6 Will Kemp 2012-04-19 19:49:00 EDT
Well, it turns out it was the disable-touchpad key. I definitely checked that, but i must have missed something!

Note You need to log in before you can comment on or make changes to this bug.