Bug 802020 - jna 3.4.0-1 binaries stripped too early, not linked with $RPM_LD_FLAGS
jna 3.4.0-1 binaries stripped too early, not linked with $RPM_LD_FLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jna (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Levente Farkas
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2012-03-10 05:07 EST by Ville Skyttä
Modified: 2012-03-11 07:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.4.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-11 07:26:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Don't strip too early, link with $RPM_LD_FLAGS (907 bytes, patch)
2012-03-10 05:07 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2012-03-10 05:07:00 EST
Created attachment 569070 [details]
Don't strip too early, link with $RPM_LD_FLAGS

jna 3.4.0-1's build strips binaries too early for debuginfo to be useful, and it's not built with $RPM_LD_FLAGS.  Fix attached, let me know if you'd like me to push and build this for devel.
Comment 1 Levente Farkas 2012-03-10 05:58:34 EST
push it or i can push if it's easier.

thanks anyway.

Note You need to log in before you can comment on or make changes to this bug.