Bug 802048 - NFS4: umount not possible if // is part of the address
NFS4: umount not possible if // is part of the address
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 09:45 EST by David Rotermund
Modified: 2012-10-12 09:35 EDT (History)
0 users

See Also:
Fixed In Version: nfs-utils-1.2.3-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 09:35:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Rotermund 2012-03-10 09:45:37 EST
Description of problem:

I ran into the following problem using SL6.2: 

If I mount a NFS4 dir like this
#cat /etc/fstab
[...]
10.10.70.9://raid_0 /9 nfs

then this results in 
#cat /etc/mtab 
[...]
10.10.70.9://raid_0 /9 nfs rw,vers=4,addr=10.10.70.9,clientaddr=10.10.70.43 0 0

and this 

#cat /proc/mounts
[...]
10.10.70.9:/raid_0/ /9 nfs4
rw,relatime,vers=4,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,por
t=0,timeo=600,retrans=2,sec=sys,clientaddr=10.10.70.43,minorversion=0,local_
lock=none,addr=10.10.70.9 0 0

Due to the different handling of the // for NFS4, I cannot unmount the directory again. If I try then I get the error 
#umount /9
/9 was not found in /proc/mounts
/9 was not found in /proc/mounts

This problem doesn't occur with NFS3 shares because the corresponding /proc/mounts entry still contains //. 

My workaround is to remove // from the /etc/fstab and change /etc/mtab on all running systems by hand.
Comment 2 RHEL Product and Program Management 2012-05-03 01:15:01 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.