Bug 802070 - [abrt] gvfs-1.10.1-3.fc16: __GI___libc_free: Process /usr/libexec/gvfsd-cdda was killed by signal 11 (SIGSEGV)
[abrt] gvfs-1.10.1-3.fc16: __GI___libc_free: Process /usr/libexec/gvfsd-cdda ...
Status: CLOSED DUPLICATE of bug 804484
Product: Fedora
Classification: Fedora
Component: libcdio (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
abrt_hash:6174ae2dda3fc382c2d8c706964...
:
: 672069 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 13:21 EST by David Van Gaal
Modified: 2012-03-21 09:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 09:40:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: bug_report (7.00 KB, text/plain)
2012-03-10 13:21 EST, David Van Gaal
no flags Details
File: maps (6.95 KB, text/plain)
2012-03-10 13:21 EST, David Van Gaal
no flags Details
File: backtrace (10.70 KB, text/plain)
2012-03-10 13:21 EST, David Van Gaal
no flags Details
File: backtrace (10.35 KB, text/plain)
2012-03-18 20:28 EDT, Stuart D Gathman
no flags Details
cd-info output (7.39 KB, text/plain)
2012-03-18 22:52 EDT, Stuart D Gathman
no flags Details
Rebuild of gvfs-1.10.1-3.fc16.src.rpm for i686 fails (15.99 KB, text/plain)
2012-03-18 23:30 EDT, Stuart D Gathman
no flags Details

  None (edit)
Description David Van Gaal 2012-03-10 13:21:40 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/libexec/gvfsd-cdda --spawner :1.4 /org/gtk/gvfs/exec_spaw/0
comment:        I inserted an audio cd.
crash_function: __GI___libc_free
executable:     /usr/libexec/gvfsd-cdda
kernel:         3.2.9-1.fc16.i686
pid:            1792
pwd:            /
reason:         Process /usr/libexec/gvfsd-cdda was killed by signal 11 (SIGSEGV)
time:           Sat 10 Mar 2012 11:07:02 AM MST
uid:            1000
username:       david

backtrace:      Text file, 10961 bytes
bug_report:     Text file, 7172 bytes
maps:           Text file, 7117 bytes

dso_list:
:/usr/lib/libcdio_paranoia.so.0.0.3 libcdio-0.82-5.fc16.i686 (Fedora Project) 1320287318
:/lib/libpthread-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234340
:/lib/libgudev-1.0.so.0.1.0 libgudev1-173-3.fc16.i686 (Fedora Project) 1320287302
:/usr/lib/libffi.so.5.0.10 libffi-3.0.10-1.fc16.i686 (Fedora Project) 1320287301
:/lib/libdbus-1.so.3.5.6 dbus-libs-1:1.4.10-3.fc16.i686 (Fedora Project) 1320287300
:/usr/lib/libgnome-keyring.so.0.1.1 libgnome-keyring-3.2.0-1.fc16.i686 (Fedora Project) 1320287302
:/lib/libgpg-error.so.0.8.0 libgpg-error-1.10-1.fc16.i686 (Fedora Project) 1320287301
:/lib/libutil-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234340
:/usr/lib/libcdio.so.12.0.0 libcdio-0.82-5.fc16.i686 (Fedora Project) 1320287318
:/lib/ld-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234340
:/lib/libudev.so.0.12.0 libudev-173-3.fc16.i686 (Fedora Project) 1320287300
:/lib/libselinux.so.1 libselinux-2.1.6-6.fc16.i686 (Fedora Project) 1329804074
:/usr/lib/libcdio_cdda.so.0.0.5 libcdio-0.82-5.fc16.i686 (Fedora Project) 1320287318
:/lib/libz.so.1.2.5 zlib-1.2.5-6.fc16.i686 (Fedora Project) 1328148969
:/lib/libdl-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234340
:/lib/libgcrypt.so.11.7.0 libgcrypt-1.5.0-2.fc16.i686 (Fedora Project) 1320287301
:/usr/lib/libgvfscommon.so.0.0.0 gvfs-1.10.1-3.fc16.i686 (Fedora Project) 1329804076
:/usr/lib/libxml2.so.2.7.8 libxml2-2.7.8-6.fc16.i686 (Fedora Project) 1320287300
:/lib/libgmodule-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1328248440
:/lib/libresolv-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234340
:/lib/librt-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234340
:/lib/libgcc_s-4.6.2-20111027.so.1 libgcc-4.6.2-1.fc16.i686 (Fedora Project) 1320287292
:/lib/libc-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234340
:/lib/libgthread-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1328248440
:/usr/lib/libbluray.so.0.0.0 libbluray-0.2-0.5.20110710git51d7d60a96d06.fc16.i686 (Fedora Project) 1320287303
:/usr/lib/locale/locale-archive glibc-common-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234331
:/lib/libgobject-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1328248440
:/lib/libm-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1330234340
:/lib/libgio-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1328248440
:/usr/libexec/gvfsd-cdda gvfs-1.10.1-3.fc16.i686 (Fedora Project) 1329804076
:/lib/libglib-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1328248440

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-hfAn9vvYcR,guid=7988e63f5724814e485e816f00000066
:XDG_SESSION_COOKIE=9d294e2e686017d1a221d9270000000f-1331402777.921813-988404483
:XDG_RUNTIME_DIR=/run/user/david
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=david
:XDG_SESSION_ID=2
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-hfAn9vvYcR,guid=7988e63f5724814e485e816f00000066
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-david-uyLLtY/database
:USER=david
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1364
:SHLVL=1
:GDM_LANG=en_US.utf8
:PWD=/home/david
:GNOME_KEYRING_CONTROL=/tmp/keyring-Djmax1
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=david
:HOME=/home/david

smolt_data:
:
:
:General
:=================================
:UUID: 2eb88017-efb0-4a20-95f9-b30f71dbc0a1
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 4388.49
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Celeron(R) CPU          900  @ 2.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 1
:CPU Speed: 2193
:System Memory: 2895
:System Swap: 3074
:Vendor: TOSHIBA
:System: Satellite L355 PSLD8U-0U9033
:Form factor: Notebook
:Kernel: 3.2.9-1.fc16.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4332:33078:4473:65382) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10818:4473:65383) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:4473:65383) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:4473:65382) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10521:4473:65382) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(32902:10568:4473:65382) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4473:65382) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10537:4473:65382) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10549:4473:65382) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10544:4473:65382) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:9288:4473:65382) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10548:4473:65382) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10551:4473:65382) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4473:65382) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(32902:10816:4473:65382) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10550:4473:65382) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10553:4473:65382) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10554:4473:65382) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4473:65382) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 6545736 4398643 4333117 1646592 1458117 1458117
:/dev/sda4 WITHHELD fuseblk 4096 4096 108175685 107025343 107025343 428166908 428151858 428151858
:

var_log_messages:
:Mar 10 11:07:02 rockstar kernel: [  146.932511] gvfsd-cdda[1793]: segfault at fffffffd ip 439c4926 sp b75d7b50 error 4 in libc-2.14.90.so[43949000+1a7000]
:Mar 10 11:07:02 rockstar abrt[1794]: Saved core dump of pid 1792 (/usr/libexec/gvfsd-cdda) to /var/spool/abrt/ccpp-2012-03-10-11:07:02-1792 (9269248 bytes)
Comment 1 David Van Gaal 2012-03-10 13:21:45 EST
Created attachment 569106 [details]
File: bug_report
Comment 2 David Van Gaal 2012-03-10 13:21:46 EST
Created attachment 569107 [details]
File: maps
Comment 3 David Van Gaal 2012-03-10 13:21:48 EST
Created attachment 569108 [details]
File: backtrace
Comment 4 Stuart D Gathman 2012-03-18 20:28:26 EDT
Inserted a CD

backtrace_rating: 4
Package: gvfs-1.10.1-3.fc16
OS Release: Fedora release 16 (Verne)
Comment 5 Stuart D Gathman 2012-03-18 20:28:31 EDT
Created attachment 570968 [details]
File: backtrace
Comment 6 Stuart D Gathman 2012-03-18 21:16:11 EDT
How do I play an audio CD?  Audio CD Extractor and Rhythmbox are both stymied by this bug!
Comment 7 Stuart D Gathman 2012-03-18 22:06:11 EDT
Hmm.  It doesn't crash on all CDs.  Only on recently produced ones.  Maybe something to do with track metadata?  Some lame copy protection scheme?
Comment 8 Stuart D Gathman 2012-03-18 22:24:20 EDT
Bug#804283 crashes in strcmp, but is otherwise very similar.  Dup?
Comment 9 Stuart D Gathman 2012-03-18 22:52:37 EDT
Created attachment 570991 [details]
cd-info output

cd-info crashes also
Comment 10 Stuart D Gathman 2012-03-18 23:30:20 EDT
Created attachment 570992 [details]
Rebuild of gvfs-1.10.1-3.fc16.src.rpm for i686 fails

rpmbuild --rebuild gvfs-1.10.1-3.fc16.src.rpm on i686 fails.
Comment 11 Stuart D Gathman 2012-03-18 23:51:32 EDT
Did rebuild on koji against latest glibc, and it still crashes.  Added bug#804484 where cd-info also crashes on CDs with cdtext.
Comment 13 Stuart D Gathman 2012-03-19 00:16:53 EDT
Trying a number of different CDs, those with no cdtext or a small number of tracks work.  Audiobooks with lots of tiny tracks seem to be what is failing.
Comment 14 Stuart D Gathman 2012-03-19 00:34:47 EDT
kscd doesn't crash, but also won't advance to next track on CDs with 99 tracks.
Comment 15 Stuart D Gathman 2012-03-19 08:33:56 EDT
vlc works perfectly.  So this is purely a software problem.
Comment 16 abrt-bot 2012-03-20 14:59:48 EDT
Backtrace analysis of bugs across components suggests the actual bug is in component libcdio instead of component gvfs, reassigning to libcdio.

Bugs which were found to be similar to this bug: 
  gvfs: bug #559068, bug #563393, bug #568096, bug #590292, bug #657581, bug #662266, bug #672069
  libcdio: bug #804484

This comment is automatically generated.
Comment 17 abrt-bot 2012-03-20 14:59:57 EDT
*** Bug 672069 has been marked as a duplicate of this bug. ***
Comment 18 Stuart D Gathman 2012-03-21 00:30:17 EDT
Fixed by patch for bug#804484.  Close?
Comment 19 Honza Horak 2012-03-21 09:40:08 EDT
(In reply to comment #18)
> Fixed by patch for bug#804484.  Close?

This really seems the same as bug #804484, so closing as duplicate.

*** This bug has been marked as a duplicate of bug 804484 ***

Note You need to log in before you can comment on or make changes to this bug.