Bug 802091 - Warn users in anaconda that they're about to install a slow debug build
Warn users in anaconda that they're about to install a slow debug build
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 19:18 EST by Paul Alesius
Modified: 2012-03-12 15:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 14:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Alesius 2012-03-10 19:18:34 EST
Description of problem:
People install pre-releases or rawhide and have slow systems due to debug builds of the kernel etc. A lot of time is wasted since people might think the slowdown is normal, or on trying to find the cause of the slowdown.

Actual results:
A very slow runtime.



Additional info:
It would be great if there was a warning, similar to the one at the beginning of an anaconda installation that says "This is a pre-release ...", that informed the user that it's a debug build and will have a great impact on performance.
Comment 1 Brian Lane 2012-03-12 14:27:44 EDT
pre-release is usually synonymous with debug builds.
Comment 2 Paul Alesius 2012-03-12 15:13:15 EDT
It's not intuitive that it will be a debug build and many people waste time on forums too trying to debug performance problems.

Note You need to log in before you can comment on or make changes to this bug.