Bug 802100 - TBf6c835f4 NCHardwareList.py:482:save:AttributeError: HwWireless instance has no attribute 'type'
TBf6c835f4 NCHardwareList.py:482:save:AttributeError: HwWireless instance has...
Status: CLOSED DUPLICATE of bug 955310
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2012-03-11 04:43 EDT by izotov
Modified: 2014-02-04 10:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-31 09:10:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
problem with saving parameters of system-config-network (1.65 KB, application/octet-stream)
2012-03-11 04:44 EDT, izotov
no flags Details

  None (edit)
Description izotov 2012-03-11 04:43:02 EDT
When I try to save system-config-network, it does not work and generates an attached bug.
Comment 1 izotov 2012-03-11 04:44:36 EDT
Created attachment 569166 [details]
problem with saving parameters of system-config-network
Comment 2 Harald Hoyer 2014-01-31 09:10:47 EST
Component: system-config-network
Version: 1.3.99.21
Summary: TBf6c835f4 NCHardwareList.py:482:save:AttributeError: HwWireless instance has no attribute 'type'

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 781, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 370, in save
    self.saveHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 398, in saveHardware
    hardwarelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 482, in save
    if (hw.Type == ETHERNET or \
AttributeError: HwWireless instance has no attribute 'type'

Local variables in innermost frame:
self: HardwareList.Wireless.eth1.Status=system
HardwareList.Wireless.eth1.Name=eth1
HardwareList.Wireless.eth1.Type=Wireless
HardwareList.Wireless.eth1.Card.ModuleName=bcm43xx
HardwareList.Wireless.eth1.Description=Broadcom Corporation BCM4311 802.11b/g WLAN
HardwareList.Ethernet.eth0.Status=system
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=tg3
HardwareList.Ethernet.eth0.Description=Broadcom Corporation NetXtreme BCM5755M Gigabit Ethernet PCI Express

modules: <netconfpkg.NCHardwareList.MyConfModules instance at 0x9e2b02c>
hw: Hardware.Status=system
Hardware.Name=eth1
Hardware.Type=Wireless
Hardware.Card.ModuleName=bcm43xx
Hardware.Description=Broadcom Corporation BCM4311 802.11b/g WLAN

wvdial: <rhpl.ConfSMB.ConfSMB instance at 0x9e2b52c>
type: Ethernet
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x9e2b2cc>
mod: eth0

*** This bug has been marked as a duplicate of bug 955310 ***

Note You need to log in before you can comment on or make changes to this bug.