Bug 802104 - event texts aren't displayed correctly
event texts aren't displayed correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
16
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 05:59 EDT by bugs
Modified: 2012-04-18 15:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: shotwell-0.10.1-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the event list (4.25 KB, image/png)
2012-03-11 05:59 EDT, bugs
no flags Details

  None (edit)
Description bugs 2012-03-11 05:59:40 EDT
Created attachment 569169 [details]
Screenshot of the event list

Description of problem:

The text of all events in the data base are not displayed correctly (see screenshot).

Version-Release number of selected component (if applicable):

shotwell-0.10.1-3.fc16.x86_64

How reproducible:

Everytime since the package upgrade.

Additional info:

This issue occures since the package upgrade from shotwell-0.10.1-1.fc16.x86_64. A downgrade resolve this issue. Accessing the database in ~/.shotwell/data/photo.db directly shows the correct event names.
Comment 1 Tim Waugh 2012-03-11 13:32:26 EDT
I see the same thing.  This makes it completely unusable.
Comment 2 JP Renaud 2012-03-18 16:13:00 EDT
I confirm this on shotwell-0.10.1-3.fc16 (32-bit). To me, this seems similar to a problem reported with vala: http://redmine.yorba.org/issues/4622
Comment 3 Kalev Lember 2012-04-13 08:24:45 EDT
I rebuilt shotwell-0.10.1-4.fc16 with vala 0.12.1, which should fix this issue. Please check if the new build fixes the regression and also leave feedback to the Fedora Update System, if possible.
Comment 4 Fedora Update System 2012-04-13 08:25:29 EDT
shotwell-0.10.1-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/shotwell-0.10.1-4.fc16
Comment 5 JP Renaud 2012-04-13 15:39:18 EDT
The shotwell-0.10.1-4.fc16 worked well for me. Event names seem to display fine on my system. Not noticed any problem so far. Thanks.
Comment 6 Fedora Update System 2012-04-13 17:34:29 EDT
Package shotwell-0.10.1-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shotwell-0.10.1-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5844/shotwell-0.10.1-4.fc16
then log in and leave karma (feedback).
Comment 7 bugs 2012-04-14 04:12:48 EDT
shotwell-0.10.1-4.fc16 works for me. event names are displayed correctly now.
Comment 8 Fedora Update System 2012-04-18 15:25:50 EDT
shotwell-0.10.1-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.