This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 802108 - SELinux is preventing /usr/bin/gtk-gnash from 'write' accesses on the archivo soundData.sol.
SELinux is preventing /usr/bin/gtk-gnash from 'write' accesses on the archivo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b1c6b552f9ee395966e675a4f9e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 06:49 EDT by camilo.ignacio
Modified: 2015-04-06 10:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 05:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description camilo.ignacio 2012-03-11 06:49:07 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc6.git0.2.fc17.x86_64
reason:         SELinux is preventing /usr/bin/gtk-gnash from 'write' accesses on the archivo soundData.sol.
time:           dom 11 mar 2012 07:48:12 CLST

description:
:SELinux is preventing /usr/bin/gtk-gnash from 'write' accesses on the archivo soundData.sol.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If cree que de manera predeterminada, gtk-gnash debería permitir acceso write sobre  soundData.sol file.     
:Then debería reportar esto como un error.
:Puede generar un módulo de política local para permitir este acceso.
:Do
:permita el acceso momentáneamente executando:
:# grep gtk-gnash /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                soundData.sol [ file ]
:Source                        gtk-gnash
:Source Path                   /usr/bin/gtk-gnash
:Port                          <Desconocido>
:Host                          (removed)
:Source RPM Packages           gnash-0.8.10-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.3.0-0.rc6.git0.2.fc17.x86_64 #1 SMP Mon Mar 5
:                              16:54:07 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    dom 11 mar 2012 07:02:27 CLST
:Last Seen                     dom 11 mar 2012 07:02:27 CLST
:Local ID                      9807f599-3656-49db-b20e-6dda77785dc6
:
:Raw Audit Messages
:type=AVC msg=audit(1331460147.888:103): avc:  denied  { write } for  pid=2110 comm="gtk-gnash" name="soundData.sol" dev="dm-3" ino=262373 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1331460147.888:103): arch=x86_64 syscall=open success=no exit=EACCES a0=fbccc8 a1=241 a2=1b6 a3=238 items=0 ppid=1810 pid=2110 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=gtk-gnash exe=/usr/bin/gtk-gnash subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gtk-gnash,mozilla_plugin_t,user_home_dir_t,file,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-12 05:13:55 EDT
What are you exactly doing?

You will need to fix labeling using

$ restorecon -R -v /home
Comment 2 camilo.ignacio 2015-04-06 10:05:23 EDT
Ok, not a bug.

Note You need to log in before you can comment on or make changes to this bug.