Bug 802119 - service network start shows error messages
Summary: service network start shows error messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.3
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: initscripts Maintenance Team
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-11 12:52 UTC by Adam Okuliar
Modified: 2012-06-20 13:09 UTC (History)
3 users (show)

Fixed In Version: initscripts-9.03.30-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:09:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0816 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2012-06-19 20:34:23 UTC

Description Adam Okuliar 2012-03-11 12:52:06 UTC
Description of problem:
service network start shows error messages

Version-Release number of selected component (if applicable):
initscripts-9.03.28-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.create network interface configuration file ifcfg-netxen2:
DEVICE=netxen2
HWADDR=00:0e:1e:02:05:a6
ONBOOT=yes
BOOTPROTO=none
IPV6INIT=yes
IPADDR=172.16.25.10
NETMASK=255.255.255.0
IPV6ADDR=fd25::10/64

2. create vlan configuration file ifcfg-vlan30 
DEVICE=vlan30
ONBOOT=yes
BOOTPROTO=none
IPV6INIT=yes
IPADDR=172.16.32.10
NETMASK=255.255.255.0
IPV6ADDR=fd32::10/64
VLAN=yes
VLAN_NAME_TYPE=VLAN_PLUS_VID_NO_PAD
PHYSDEV=netxen2
  
Actual results:

# ifup netxen2
Usage: ip addr {add|change|replace} IFADDR dev STRING [ LIFETIME ]
                                                      [ CONFFLAG-LIST]
       ip addr del IFADDR dev STRING
       ip addr {show|flush} [ dev STRING ] [ scope SCOPE-ID ]
                            [ to PREFIX ] [ FLAG-LIST ] [ label PATTERN ]
IFADDR := PREFIX | ADDR peer PREFIX
          [ broadcast ADDR ] [ anycast ADDR ]
          [ label STRING ] [ scope SCOPE-ID ]
SCOPE-ID := [ host | link | global | NUMBER ]
FLAG-LIST := [ FLAG-LIST ] FLAG
FLAG  := [ permanent | dynamic | secondary | primary |
           tentative | deprecated | CONFFLAG-LIST ]
CONFFLAG-LIST := [ CONFFLAG-LIST ] CONFFLAG
CONFFLAG  := [ home | nodad ]
LIFETIME := [ valid_lft LFT ] [ preferred_lft LFT ]
LFT := forever | SECONDS


# ifup vlan20
Error: either "dev" is duplicate, or "20" is a garbage.

Expected results:
No error messages during network startup

Comment 2 Bill Nottingham 2012-03-12 16:44:20 UTC
Does http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=6ddce805ccecb7f02a31a413c501217336e3791a fix this for you? (It works in brief testing for me.)

Comment 3 Adam Okuliar 2012-03-15 12:53:25 UTC
Hi,

Patch works well, no error messages appeared and network was configured correctly.

Thanks,
Adam

Comment 9 Adam Okuliar 2012-03-21 10:58:07 UTC
verified on Linux redclient-02.rhts.bos.redhat.com 2.6.32-251.el6.x86_64 #1 SMP Fri Mar 9 12:48:43 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

rpm -q initscripts
initscripts-9.03.30-1.el6.x86_64

Comment 10 errata-xmlrpc 2012-06-20 13:09:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0816.html


Note You need to log in before you can comment on or make changes to this bug.