Bug 802136 - SELinux is preventing /usr/lib/virtualbox/VBoxSVC from 'create' accesses on the dossier BOINC_VM.
SELinux is preventing /usr/lib/virtualbox/VBoxSVC from 'create' accesses on t...
Status: CLOSED DUPLICATE of bug 796935
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:930a717440bb023ee739b5179b5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 12:07 EDT by Pascal94
Modified: 2012-03-12 04:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 04:07:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pascal94 2012-03-11 12:07:54 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.9-2.fc16.x86_64
reason:         SELinux is preventing /usr/lib/virtualbox/VBoxSVC from 'create' accesses on the dossier BOINC_VM.
time:           dim. 11 mars 2012 17:07:45 CET

description:
:SELinux is preventing /usr/lib/virtualbox/VBoxSVC from 'create' accesses on the dossier BOINC_VM.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that VBoxSVC should be allowed create access on the BOINC_VM directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep VBoxSVC /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:boinc_project_t:s0
:Target Context                system_u:object_r:boinc_var_lib_t:s0
:Target Objects                BOINC_VM [ dir ]
:Source                        VBoxSVC
:Source Path                   /usr/lib/virtualbox/VBoxSVC
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           VirtualBox-4.1-4.1.8_75467_fedora16-1.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-78.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux CM-ELITE-341 3.2.9-2.fc16.x86_64 #1 SMP Mon
:                              Mar 5 20:55:39 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    dim. 11 mars 2012 17:04:47 CET
:Last Seen                     dim. 11 mars 2012 17:04:47 CET
:Local ID                      d6362d62-8f5c-43e0-a740-6bdf817c6a5a
:
:Raw Audit Messages
:type=AVC msg=audit(1331481887.490:252): avc:  denied  { create } for  pid=6112 comm="VBoxSVC" name="BOINC_VM" scontext=system_u:system_r:boinc_project_t:s0 tcontext=system_u:object_r:boinc_var_lib_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1331481887.490:252): arch=x86_64 syscall=mkdir success=yes exit=0 a0=7fba9ab655e0 a1=1ff a2=0 a3=562f636e696f622f items=0 ppid=1 pid=6112 auid=4294967295 uid=993 gid=990 euid=993 suid=993 fsuid=993 egid=990 sgid=990 fsgid=990 tty=(none) ses=4294967295 comm=VBoxSVC exe=/usr/lib/virtualbox/VBoxSVC subj=system_u:system_r:boinc_project_t:s0 key=(null)
:
:Hash: VBoxSVC,boinc_project_t,boinc_var_lib_t,dir,create
:
:audit2allow
:
:#============= boinc_project_t ==============
:allow boinc_project_t boinc_var_lib_t:dir create;
:
:audit2allow -R
:
:#============= boinc_project_t ==============
:allow boinc_project_t boinc_var_lib_t:dir create;
:
Comment 1 Miroslav Grepl 2012-03-12 04:07:56 EDT

*** This bug has been marked as a duplicate of bug 796935 ***

Note You need to log in before you can comment on or make changes to this bug.