This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 802144 - [abrt] kernel: [ INFO: possible recursive locking detected ]
[abrt] kernel: [ INFO: possible recursive locking detected ]
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:d783735b94f8062093a1abf2e51...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 13:15 EDT by Sean Beeson
Modified: 2012-03-12 09:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 09:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Beeson 2012-03-11 13:15:27 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.0.17-1.rt33.1.fc16.ccrma.i686.rtPAE root=/dev/mapper/vg_pod-lv_root ro rd.md=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 rd.lvm.lv=vg_pod/lv_root rd.lvm.lv=vg_pod/lv_swap LANG=en_US.UTF-8
kernel:         3.0.17-1.rt33.1.fc16.ccrma.i686.rtPAE
reason:         [ INFO: possible recursive locking detected ]
time:           Mon 12 Mar 2012 01:58:09 AM JST

backtrace:
:[ INFO: possible recursive locking detected ]
:3.0.17-1.rt33.1.fc16.ccrma.i686.rtPAE #1
:---------------------------------------------
:KorgKontrolEdit/2639 is trying to acquire lock:
: (&grp->list_mutex){+++++.}, at: [<c047ca24>] rt_down_read+0xf/0x11
:but task is already holding lock:
: (&grp->list_mutex){+++++.}, at: [<f8279d5b>] snd_seq_port_disconnect+0x24/0x12f [snd_seq]
:other info that might help us debug this:
: Possible unsafe locking scenario:
:       CPU0
:       ----
:  lock(&grp->list_mutex);
:  lock(&grp->list_mutex);
: *** DEADLOCK ***
: May be due to missing lock nesting notation
:2 locks held by KorgKontrolEdit/2639:
: #0:  (&grp->list_mutex){+++++.}, at: [<f8279d5b>] snd_seq_port_disconnect+0x24/0x12f [snd_seq]
: #1:  (&grp->list_mutex/1){+.+.+.}, at: [<f8279d6e>] snd_seq_port_disconnect+0x37/0x12f [snd_seq]
:stack backtrace:
:Pid: 2639, comm: KorgKontrolEdit Not tainted 3.0.17-1.rt33.1.fc16.ccrma.i686.rtPAE #1
:Call Trace:
: [<c085b4cd>] ? printk+0x2d/0x2f
: [<c04770e8>] __lock_acquire+0x811/0xb63
: [<c0469385>] ? local_clock+0x32/0x49
: [<c0474c94>] ? lock_release_holdtime.part.10+0x4b/0x51
: [<c047ca24>] ? rt_down_read+0xf/0x11
: [<c04778bb>] lock_acquire+0xde/0x11d
: [<c047ca24>] ? rt_down_read+0xf/0x11
: [<c047c9e5>] __rt_down_read+0x36/0x57
: [<c047ca24>] ? rt_down_read+0xf/0x11
: [<c047ca24>] rt_down_read+0xf/0x11
: [<f827562a>] snd_seq_deliver_event+0xdc/0x1df [snd_seq]
: [<c04777b7>] ? lock_release+0x191/0x1b7
: [<f8275b51>] snd_seq_kernel_client_dispatch+0x84/0x98 [snd_seq]
: [<f8428071>] dummy_unuse+0x62/0x9c [snd_seq_dummy]
: [<f82790b8>] unsubscribe_port+0x44/0x77 [snd_seq]
: [<f8279e27>] snd_seq_port_disconnect+0xf0/0x12f [snd_seq]
: [<f8275dbf>] snd_seq_ioctl_unsubscribe_port+0xb8/0x132 [snd_seq]
: [<f82749eb>] snd_seq_do_ioctl+0x65/0xb2 [snd_seq]
: [<c05b709d>] ? file_has_perm+0xa5/0xbe
: [<f8274a38>] ? snd_seq_do_ioctl+0xb2/0xb2 [snd_seq]
: [<f8274a7d>] snd_seq_ioctl+0x45/0x47 [snd_seq]
: [<c0517efa>] do_vfs_ioctl+0x485/0x4b6
: [<c05b7614>] ? selinux_file_ioctl+0xac/0xb0
: [<c0517f73>] sys_ioctl+0x48/0x69
: [<c08641bc>] syscall_call+0x7/0xb
: [<c0860033>] ? cmos_do_probe+0x107/0x3e5

smolt_data:
:
:
:General
:=================================
:UUID: c8696a24-47bc-43ba-8943-7c7c96e572b3
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 2392.55
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Pentium(R) M processor 1200MHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 9
:Number of CPUs: 1
:CPU Speed: 1200
:System Memory: 1169
:System Swap: 2495
:Vendor: IBM
:System: 237167U ThinkPad X40
:Form factor: Notebook
:Kernel: 3.0.17-1.rt33.1.fc16.ccrma.i686.rtPAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:4215:4116:1371) pci, e1000, ETHERNET, 82541GI Gigabit Ethernet Controller
:(32902:9415:4116:1325) pci, uhci_hcd, USB, ThinkPad
:(5772:4116:6059:33585) pci, ath5k, ETHERNET, AR5212 802.11abg NIC
:(4480:1142:4116:1365) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:(32902:13698:4116:1367) pci, i915, VIDEO, 82852/855GM Integrated Graphics Device
:(32902:13698:4116:1367) pci, None, VIDEO, 82852/855GM Integrated Graphics Device
:(32902:9418:4116:1325) pci, ata_piix, STORAGE, ThinkPad
:(32902:9420:0:0) pci, None, PCI/ISA, 82801DBM (ICH4-M) LPC Interface Bridge
:(32902:9414:4116:1369) pci, Intel ICH Modem, SIMPLE, ThinkPad R50e
:(32902:9413:4116:1368) pci, Intel ICH, MULTIMEDIA_AUDIO, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
:(32902:9411:4116:1325) pci, i801_smbus, SERIAL, ThinkPad
:(32902:9288:0:0) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(4480:2082:4116:1366) pci, sdhci-pci, BASE, ThinkPad X60s / Z60t
:(32902:9410:4116:1325) pci, uhci_hcd, USB, ThinkPad
:(32902:9412:4116:1325) pci, uhci_hcd, USB, ThinkPad
:(32902:13701:4116:1374) pci, None, BASE, ThinkPad R50e
:(32902:13696:4116:1372) pci, agpgart-intel, HOST/PCI, ThinkPad R50e
:(32902:13700:4116:1373) pci, None, BASE, ThinkPad R50e
:(32902:9421:4116:1326) pci, ehci_hcd, USB, ThinkPad
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_pod-lv_root / ext4 4096 4096 8853418 7675239 7225499 2252800 2087345 2087345
:/dev/sda1 /boot ext4 1024 1024 495844 436578 410978 128016 127793 127793
:/dev/sdb1 WITHHELD vfat 4096 4096 996403 179595 179595 0 0 0
:
Comment 1 Josh Boyer 2012-03-12 09:58:59 EDT

*** This bug has been marked as a duplicate of bug 126342 ***

Note You need to log in before you can comment on or make changes to this bug.