Bug 802212 - Failed to create scalable app via REST API or CLI
Failed to create scalable app via REST API or CLI
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 02:00 EDT by jizhao
Modified: 2015-05-14 18:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 04:53:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output log (1.64 KB, text/plain)
2012-03-12 02:07 EDT, jizhao
no flags Details

  None (edit)
Description jizhao 2012-03-12 02:00:48 EDT
Description of problem:
Meet StickShift::NodeException: Node execution failure (invalid exit code from node) while creating a scalable app using REST API or rhc client,
Error log in development.log:
DEBUG: server results: Failed to start /var/lib/stickshift/adf4836ae23c4cb7a6779118fafb30fe/phpscale2/phpscale2_ctl.sh
Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.
#<StickShift::NodeException: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.>
 
 
Version-Release number of selected component (if applicable):
rhc-cartridge-haproxy-1.4-0.6.4-1.el6_2.noarch
rhc-broker-0.88.3-1.el6_2.noarch
rhc-node-0.88.4-1.el6_2.x86_64
stickshift-abstract-0.6.5-1.el6_2.noarch
rubygem-stickshift-node-0.6.6-1.el6_2.noarch
rubygem-stickshift-common-0.6.4-1.el6_2.noarch
rubygem-stickshift-controller-0.6.5-1.el6_2.noarch
 
 
 
How reproducible:
Always
 
Steps to Reproduce:
1.Create an scalable app using REST API
$ curl -k -H "Accept: application/xml" --user "jizhao+3@redhat.com:redhat"  https://ec2-107-22-54-22.compute-1.amazonaws.com/broker/rest/domains/jizhaotest/applications -X POST -d name=app3 -d cartridge=php-5.3 -d scale=true
 
 
Actual results:
 
The app is created, but not available.
<------------console output-------------->
  <title>Action Controller: Exception caught</title>
 
<h1>
  StickShift::NodeException
    in ApplicationsController#create
</h1>
<pre>Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.</pre>
<--------------------------------------->
 
Expected results:
The app should be created successfully.
 
Additional info:
Comment 1 jizhao 2012-03-12 02:07:47 EDT
Created attachment 569279 [details]
Output log
Comment 2 jizhao 2012-03-12 04:48:23 EDT
This bug is probably caused by Bug 802258:
https://bugzilla.redhat.com/show_bug.cgi?id=802258
Comment 3 jizhao 2012-03-12 04:53:04 EDT
This bug is fixed after the workaround steps of Bug 802258.

Note You need to log in before you can comment on or make changes to this bug.