Bug 802217 - [3.3.0qa26] glusterd.info file is not readable by non-root users
[3.3.0qa26] glusterd.info file is not readable by non-root users
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.3-beta
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Vivek Agarwal
Ujjwala
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-12 02:35 EDT by Bala.FA
Modified: 2016-02-17 19:03 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:19:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: glusterfs-server-3.3.0qa45-1.el6.x86_64
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bala.FA 2012-03-12 02:35:02 EDT
Description of problem:
vdsm gluster plugin get peers list and adds local server info to it by reading /etc/gluster/glusterd.info file.  In the qa26 release, the file path is /var/lib/glusterd/glusterd.info is not readable by non-root users.  vdsmd runs as vdsm user and hostsList gluster verbs fails due to this.

Either we need the file readable or a gluster command to get this info.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2012-03-14 06:00:24 EDT
CHANGE: http://review.gluster.com/2940 (glusterd: file perm change for glusterd.info) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 2 Bala.FA 2012-03-20 06:43:04 EDT
qa30 doesn't have this bug in fresh install, but appearing if rpm -Uvh is done.
I think this is OK as these are all qa releases.
Comment 3 Gowrishankar Rajaiyan 2012-05-30 05:49:42 EDT
[root@dhcp201-221 ~]# ls -l /var/lib/glusterd/glusterd.info
-rw-r--r--. 1 root root 42 May 29 18:03 /var/lib/glusterd/glusterd.info


glusterd.info file is now readable by non-root users.

Verified: glusterfs-server-3.3.0qa45-1.el6.x86_64

Note You need to log in before you can comment on or make changes to this bug.