Bug 802226 - Back to userspace when fail to allocate ioeventfd
Back to userspace when fail to allocate ioeventfd
Status: CLOSED DUPLICATE of bug 753692
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 03:26 EDT by Amos Kong
Modified: 2015-05-24 20:06 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 03:59:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amos Kong 2012-03-12 03:26:29 EDT
Description of problem:

If we support pci-bridge, we would have more pci-devices.
Then kernel could not provide enough ioeventfd, virtio net/blk should go back to userspace when fail to allocate ioeventfd, not exit.


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.233


How reproducible:
100%

Steps to Reproduce:
1. boot up guest with 232 virtio-blk

result: 
qemu would exit and output "unable to map ioeventfd: -28"
Comment 1 Amos Kong 2012-03-12 03:59:30 EDT
Talked with mst, we need to resolve bz 753692 by go back
to userspace when fail to allocate ioeventfd.

Need to open a new bug for my kernel fix+backport (bsearch lookup iobus devices)

*** This bug has been marked as a duplicate of bug 753692 ***

Note You need to log in before you can comment on or make changes to this bug.