Bug 802375 - BIND cannot be shutdown correctly, if psearch is enabled and LDAP connect fails
BIND cannot be shutdown correctly, if psearch is enabled and LDAP connect fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind-dyndb-ldap (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Adam Tkac
Namita Soman
:
Depends On:
Blocks: 733711 827414
  Show dependency treegraph
 
Reported: 2012-03-12 08:08 EDT by Petr Spacek
Modified: 2015-05-20 11:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:57:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server was shutdown, but psearch watcher still runs and holds named process. (1.16 KB, application/octet-stream)
2012-03-12 08:08 EDT, Petr Spacek
no flags Details

  None (edit)
Description Petr Spacek 2012-03-12 08:08:24 EDT
Created attachment 569371 [details]
Server was shutdown, but psearch watcher still runs and holds named process.

Description of problem:
If connection with LDAP server cannot be established, it is not possible to shutdown BIND correctly. (Example situation: Admin made mistake in LDAP server URI or server network/LDAP server is not functional.)


Version-Release number of selected component (if applicable):
bind-dyndb-ldap-1.1.0-0.3.b1.el6

Steps to Reproduce:
1. Set uri parameter in /etc/named.conf to nonsense (ex. ldap://127.0.0.1:111)
2. run BIND (systemctl start named.service)
3. try to stop BIND via rndc stop or rndc halt

Actual results:
BIND still runs.

Expected results:
BIND was shutdown correctly.

Additional info:
Upstream ticket: https://fedorahosted.org/bind-dyndb-ldap/ticket/55
Fixed in upstream: https://fedorahosted.org/bind-dyndb-ldap/changeset/55d2886bb016adf3081a25eea616ce40f17d03e4
Comment 5 Petr Spacek 2012-03-23 11:00:19 EDT
Persistent search feature postponed to 6.4, as discussed with Dmitri Pal and Jenny Galipeau.
Comment 9 Namita Soman 2013-01-07 11:52:52 EST
Verified using:
ipa-server-3.0.0-19.el6.x86_64
bind-dyndb-ldap-2.3-1.el6.x86_64


Steps taken to verify:
# grep psearch /etc/named.conf 
	arg "psearch yes";


# service named status
version: 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6
CPUs found: 2
worker threads: 2
number of zones: 21
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/0/1000
tcp clients: 0/100
server is up and running
named (pid  11954) is running...

# vim /etc/named.conf 
 => Updated line to be:
  #arg "uri ldapi://%2fvar%2frun%2fslapd-TESTRELM-COM.socket";
  arg "uri ldapi://127.0.0.1:111";

# service named restart
Stopping named: .[  OK  ]
Starting named: [  OK  ]

# pgrep named
23762

# rndc -V stop
create memory context
create socket manager
create task manager
create task
create logging context
setting log tag
creating log channel
enabling log channel
create parser
get key
decode base64 secret
stop
post event
using server 127.0.0.1 (127.0.0.1#953)
create socket
bind socket
connect
create message
render message
schedule recv
send message
parse message
create message
render message
schedule recv
send message
parse message

# service named status
rndc: connect failed: 127.0.0.1#953: connection refused
named dead but subsys locked

[root@ipaqa64vma ~]# pgrep named
[root@ipaqa64vma ~]# 

Verified that BIND was shutdown correctly.

edited /etc/named.conf to go back to original line, and restarted named sucessfully after the test above.
Comment 11 errata-xmlrpc 2013-02-21 03:57:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0359.html

Note You need to log in before you can comment on or make changes to this bug.