Bug 802407 - Crash in boot Xen 4.1.2 + kernel-3.2.9-2.fc16.x86_64
Crash in boot Xen 4.1.2 + kernel-3.2.9-2.fc16.x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 09:42 EDT by Volnei
Modified: 2012-03-19 09:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 09:35:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
message log (77.48 KB, text/plain)
2012-03-12 09:42 EDT, Volnei
no flags Details
Log containing error messages during boot (91.72 KB, application/octet-stream)
2012-03-15 09:01 EDT, Volnei
no flags Details

  None (edit)
Description Volnei 2012-03-12 09:42:18 EDT
Created attachment 569393 [details]
message log

Description of problem:

After updating the kernel the system hangs during boot.
Locking the runs using the Xen kernel + kernel and use only the problem
acontence not.

The only message I could retrieve this attached.

If you need more information please can ask

Thanks



Version-Release number of selected component (if applicable):

Fedora 16 x86_64

kernel-3.2.9-1.fc16.x86_64
kernel-3.2.9-2.fc16.x86_64
kernel-devel-3.2.9-1.fc16.x86_64
kernel-devel-3.2.9-2.fc16.x86_64
kernel-headers-3.2.9-2.fc16.x86_64


netxen-firmware-4.0.534-4.fc15.noarch
xen-4.1.2-6.fc16.x86_64
xen-libs-4.1.2-6.fc16.x86_64
xen-hypervisor-4.1.2-6.fc16.x86_64
xen-licenses-4.1.2-6.fc16.x86_64
xen-runtime-4.1.2-6.fc16.x86_64


Mother board: MSI MS-7592/G41M-S01 (MS-7592), BIOS V26.6 03/02/2011

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Volnei 2012-03-15 09:01:53 EDT
Created attachment 570287 [details]
Log containing error messages during boot

The attached file contains the log with error messages, which
I think are relevant to the analysis.

Thanks
Comment 2 Michael Young 2012-03-17 09:04:36 EDT
I am seeing this as well - 3.2.9-1 works, 3.2.9-2 crashes early in the boot, as does 3.2.10-3. I don't have a good way of recording the crashes but did manage to write down some information from the 3.2.10-3 crash, it was a NULL pointer dereference at _xen_irq_init+0x1f/0xb0
Comment 3 Michael Young 2012-03-17 10:16:34 EDT
(In reply to comment #2)
> I am seeing this as well - 3.2.9-1 works, 3.2.9-2 crashes early in the boot, as
> does 3.2.10-3. I don't have a good way of recording the crashes but did manage
> to write down some information from the 3.2.10-3 crash, it was a NULL pointer
> dereference at _xen_irq_init+0x1f/0xb0

Actually it turns out that there are two different crashes. I have a second computer that works with 3.2.9-2 and crashes with 3.2.9-4, 3.2.10-1 and 3,2.10-3.
At a guess I would say the 3.2.9-2 crash is caused by the irqpoll patch which might perhaps be fixed in later versions, but 3.2.9-4 and following are crashing earlier due to something else, perhaps the io-apic entries patch.
Comment 4 Volnei 2012-03-19 07:31:38 EDT
Hi,

Now the crash is happening on all machines with Xen, using the new 
kernel-3.2.10-3.fc16.x86_64.

Just doesno't happen with kernel-devel-3.2.9-1.fc16.x86_64.
The kernel-3.2.9-2.fc16.x86_64 worked at motherboard Intel S1200BTL.
The new version kernel-3.2.10-3.fc16.x86_64 doesn't work.

This is a very serious problem!
Comment 5 Michael Young 2012-03-19 07:52:38 EDT
Actually I think this particular bug is fixed in the current F16 code, you are being now hit by the separate bug 804347 . I did a scratch build of the current F16 code without the x86-ioapic-add-register-checks-for-bogus-io-apic-entries.patch patch for testing purposes at http://koji.fedoraproject.org/koji/taskinfo?taskID=3905600 and it boots dom0 on the box that was hit by this bug.
Comment 6 Volnei 2012-03-19 08:42:48 EDT
Ok, but when these bugs will be solved? 
If you need any aditional information, please ask me.

Thanks
Comment 7 Josh Boyer 2012-03-19 09:35:26 EDT
Thanks Michael.  We'll close this bug out and track the ioapic issue in the other bug you opened.

Note You need to log in before you can comment on or make changes to this bug.