Bug 802483 - Unnecessary requirement on mysql-libs
Unnecessary requirement on mysql-libs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: postfix (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
: FastFix, Patch
Depends On:
Blocks: 1373253
  Show dependency treegraph
 
Reported: 2012-03-12 12:40 EDT by Todd Zullinger
Modified: 2017-09-06 03:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-06 03:31:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backported fix (1.34 KB, patch)
2012-03-13 04:38 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Todd Zullinger 2012-03-12 12:40:48 EDT
The current postfix packages contain an unnecessary excplicit requirement on mysql-libs.  This was dropped from the Fedora packages in 2010, but after el6 was branched.  For anyone that has a need to use the MySQL packages from upstream, it makes postfix difficult to install, as installing mysql-libs along with the MySQL\* packages from upstream is not wise.

The mysql-libs requirement should be dropped.  The automatic rpm deps already pick up libmysqlclient.so.16(), so the explicit mysql-libs requirement is redundant.
Comment 2 Jaroslav Škarvada 2012-03-13 04:38:18 EDT
Created attachment 569597 [details]
Backported fix

I think we could drop more.
Comment 3 Todd Zullinger 2012-03-13 10:51:17 EDT
Indeed.  That looks to cover most of what Miroslav dropped from the Fedora packages a while back¹.  The requires on setup >= 2.5.36 was dropped there too, and may be worth dropping in the RHEL packages.  RHEL5 has 2.5.58, RHEL6 is on 2.8.x.  But that's not one that should cause anyone any trouble.

Thanks for taking a look Jaraslav.

¹ http://pkgs.fedoraproject.org/gitweb/?p=postfix.git;a=commitdiff;h=55c883d
Comment 4 RHEL Product and Program Management 2012-09-07 01:11:27 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Jaroslav Škarvada 2013-02-27 04:12:51 EST
RHEL-5.9 bug 915901
Comment 8 RHEL Product and Program Management 2013-10-13 20:46:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 13 Tomáš Hozza 2017-09-06 03:31:45 EDT
Red Hat Enterprise Linux 6 transitioned to the Production 3 Phase on May 10, 2017.  During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:
http://redhat.com/rhel/lifecycle

This issue does not appear to meet the inclusion criteria for the Production Phase 3 and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification.  Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com

Note You need to log in before you can comment on or make changes to this bug.