Bug 80251 - Ctrl-Alt-F1 generates inappropriate X11 keypress event
Ctrl-Alt-F1 generates inappropriate X11 keypress event
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-23 05:01 EST by Alexandre Oliva
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 09:56:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-12-23 05:02:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
If focus is on a gnome-terminal, switching to a text-mode virtual terminal
generates garbage on it.  It doesn' t on other applications, such as emacs or
xchat, so I'm thinking it may be specific to gnome-terminal.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set focus on a gnome-terminal
2.Enter Ctrl-Alt-F1
3.Enter Ctrl-Alt-F7
    

Actual Results:  You hear a beep, and when you switch back to X, you find that
the sequence `;7~' was entered in the terminal.

Expected Results:  It shouldn't generate any input for this sequence.

Additional info:
Comment 1 Havoc Pennington 2002-12-23 11:07:18 EST
btw, anything having to do with the terminal part of the terminal (vs. the menus
and command line options and so on) should be filed under vte, which is the 
terminal emulator itself.

Sounds like this could be X's fault though, apps don't even get any events on VT
switch.
Comment 2 Alexandre Oliva 2002-12-23 12:03:17 EST
These are the events I get when I press Ctrl-Alt-F1.

KeyPress event, serial 20, synthetic NO, window 0x2a00001,
    root 0x3f, subw 0x0, time 17216918, (76,64), root:(753,591),
    state 0x0, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes:  ""
 
KeyPress event, serial 25, synthetic NO, window 0x2a00001,
    root 0x3f, subw 0x0, time 17217295, (76,64), root:(753,591),
    state 0x4, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:  ""
 
KeyPress event, serial 25, synthetic NO, window 0x2a00001,
    root 0x3f, subw 0x0, time 17221803, (76,64), root:(753,591),
    state 0xc, keycode 67 (keysym 0xffc8, F11), same_screen YES,
    XLookupString gives 0 bytes:  ""
 
VisibilityNotify event, serial 25, synthetic NO, window 0x2a00001,
    state VisibilityFullyObscured

The reference to F11 looks inappropriate, indeed.  I'm changing this to XFree86.
Comment 3 Mike A. Harris 2002-12-26 21:27:12 EST
Attach screenshots + logs + configs please.
Comment 4 Alexandre Oliva 2002-12-26 23:37:21 EST
What kind of screenshots do you want?  What logs?  Want me to also record the
sound of the beep that bash generates because one of the characters is not
valid? :-)

Seriously, I don't see what additional information might be needed.  The bug
shows up here on my end on all machines I've got that are running phoebe, that
all have different configurations.  The very fact that an X event is generated
when F1 is pressed when Ctrl and Alt are depressed indicates a bug, no?  Did you
have any problem duplicating that event with XFree86 as in Phoebe?
Comment 5 Mike A. Harris 2002-12-27 00:00:49 EST
>What kind of screenshots do you want?

Obviously I want a screenshot of the corruption you are seeing.

>What logs?

Obviously I want the X server log, config file and other standard file
attachements that are required for pretty much every single XFree86 bug
report in order to aide in diagnosis.

>Want me to also record the sound of the beep that bash generates
>because one of the characters is not valid? :-)

If you think that would be conducive to understanding the problem.

>Seriously, I don't see what additional information might be needed.

The information that I've requested of course, unless you want me to
not bother investigating this issue further.

>The bug shows up here on my end on all machines I've got that are
>running phoebe, that all have different configurations.

Well, I _am_ running XFree86 from phoebe, however I am not running phoebe
itself, as Red Hat has not shipped me CDs yet.

>The very fact that an X event is generated when F1 is pressed when
>Ctrl and Alt are depressed indicates a bug, no?  Did you have any
>problem duplicating that event with XFree86 as in Phoebe?

Well, considering I am not running phoebe, and wont likely be for at least
a week if not 2, that is a big no.  Which is why if you want me to investigate
the issue, you might provide more information.

I assure you, that the XFree86 from phoebe runs fine and does not produce
the problem you describe, when running in Red Hat LInux 8.0, which to me
so far indicates that it is not an XFree86 problem.  However, rather than
close this as NOTABUG or WORKSFORME, I am asking you to provide information
to help me determine if it is in fact a bug or not.  The more information
provided by _you_, the less wasted hours of work for _me_ on a problem that
might actually not be an XFree86 bug afterall, hence asking for maximal
information from the outset in bug reports.  I don't have time to set up
a special XFree86 configuration for every single bug report that comes in,
in particular when a large portion of them tend to not be reproduceable in
the first place.

Awaiting that info.






Comment 6 Alexandre Oliva 2002-12-27 00:25:29 EST
The only corruption I'm seeing is a sequence of characters that is generated as
the result of an event that shouldn't be generated.  I've just tried to
duplicate the problem on my wife's account on her desktop (I'd only tried as
myself and root on my desktop and my laptop, always getting the same results),
that also runs Phoebe, and results were slightly different.  I didn't get the
same junk that I get on mine, but rather, only once, I got a difference piece of
junk, and only when I switched *back* to X.  It seems that this is
timing-sensitive, and also the passing of junk to  the gnome-terminal-started
application is disabled if menu mnemonics are not disabled in Edit -> Keybindings.

However, in all cases, pressing Ctrl-Alt-F1 with focus on an xev window has
generated an event for F1.  Do you really not get an event like this?
Comment 7 Mike A. Harris 2002-12-30 02:56:56 EST
Ok, I read too much into your original statement of "garbage" interpreting it
as random screen corruption, something potentially a 2D acceleration issue.

I now understand what it is you are meaning.  Now that you've clarified the
problem, and I know what to look for, I have done a clean XFree86 install of
phoebe's X on 8.0, and have attempted what you've supplied above verbatim.
I am now able to reproduce this as follows:

1) Run xev
2) Press CTRL-ALT-F1 then let go
3) Either press ALT-F7, or, ALT-RIGHT_ARROW over to console 7

Upon entering back into X, xev reports F1 as being pressed as you have
described above.  Although it isn't likely to matter, for the record just
for completeness, I was using a Rage IIC with the vesa driver.

Problem now confirmed.
Comment 8 Mike A. Harris 2003-01-03 15:24:43 EST
 674. XKB programable 'special combinations' (such as Ctrl+Alt+<key>)
      also send usual key evants (press and release).  Although the
      keysym generated in this case is NoSymbol such events can confuse
      some applications (#5546, Ivan Pascal).

Fixed in current build.
Comment 9 Mike A. Harris 2003-01-07 07:42:43 EST
Please resolve RAWHIDE once tested and confirmed fixed.  Works for me so far.
Comment 10 Alexandre Oliva 2003-01-23 09:56:03 EST
Confirmed fixed in phoebe2.

Note You need to log in before you can comment on or make changes to this bug.